summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-07-12 19:45:39 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-07-12 19:45:39 -0400
commit3f53f0d6308007133b3a9d58f351ac882fde50d6 (patch)
tree0ebd3e6e167d3b17702c736e88bbe74d592c33aa /games-puzzle
parentscratch & sqeak (diff)
downloadsuperposition-3f53f0d6308007133b3a9d58f351ac882fde50d6.tar.gz
superposition-3f53f0d6308007133b3a9d58f351ac882fde50d6.tar.bz2
superposition-3f53f0d6308007133b3a9d58f351ac882fde50d6.zip
bridge constructor
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/bridge-constructor/bridge-constructor-2.6.1.ebuild47
-rw-r--r--games-puzzle/bridge-constructor/metadata.xml9
2 files changed, 56 insertions, 0 deletions
diff --git a/games-puzzle/bridge-constructor/bridge-constructor-2.6.1.ebuild b/games-puzzle/bridge-constructor/bridge-constructor-2.6.1.ebuild
new file mode 100644
index 0000000..eb12019
--- /dev/null
+++ b/games-puzzle/bridge-constructor/bridge-constructor-2.6.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit unpacker eutils
+
+DESCRIPTION="Become an appraised bridge engineer and architect in Bridge Constructor"
+HOMEPAGE="http://www.headupgames.com/conpresso/_rubric/index.php?rubric=EN+Games+Bridge-Constructor"
+SRC_URI="bridgeconstructor_linux_1390863101.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="bindist fetch"
+
+MYGAMEDIR=/opt/${PN}
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ insinto ${MYGAMEDIR}
+ exeinto ${MYGAMEDIR}
+ doexe "BridgeConstructor.x86"
+ doins -r BridgeConstructor_Data
+
+ newicon -s 128 BridgeConstructor_Data/ScreenSelector.png ${PN}.png
+ make_wrapper ${PN} "./BridgeConstructor.x86" "${MYGAMEDIR}"
+ make_desktop_entry "${PN}" "Bridge Constructor" "${PN}" "Game"
+
+ domenu ${PN}
+
+}
diff --git a/games-puzzle/bridge-constructor/metadata.xml b/games-puzzle/bridge-constructor/metadata.xml
new file mode 100644
index 0000000..f9e09ed
--- /dev/null
+++ b/games-puzzle/bridge-constructor/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>phil_miess@yahoo.com</email>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>