summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-10-16 21:48:37 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-10-16 21:48:37 -0400
commit3069208969126067e4a7be1370eae33952e6a23e (patch)
tree906a59aaf443d1442a44a01e941be49ff4508346 /games-rpg
parentspell ultratron correctly (diff)
downloadsuperposition-3069208969126067e4a7be1370eae33952e6a23e.tar.gz
superposition-3069208969126067e4a7be1370eae33952e6a23e.tar.bz2
superposition-3069208969126067e4a7be1370eae33952e6a23e.zip
kelvin and the infamouse machine
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/infamousmachine/Manifest3
-rw-r--r--games-rpg/infamousmachine/infamousmachine-1.ebuild61
-rw-r--r--games-rpg/infamousmachine/metadata.xml13
3 files changed, 77 insertions, 0 deletions
diff --git a/games-rpg/infamousmachine/Manifest b/games-rpg/infamousmachine/Manifest
new file mode 100644
index 0000000..3d51699
--- /dev/null
+++ b/games-rpg/infamousmachine/Manifest
@@ -0,0 +1,3 @@
+DIST infamousmachine_unix_1_0.sh.zip 239896979 SHA256 99ff9f53e6bc24d20627890732643e53969ee43fa00cdcb634be079f4891afd8 SHA512 967566d48a400c5e358dbe52d6058b06f3f1467c50bca12cbc9fc181b2bcfdd821c16fc2d44328a9da1e038298d82e85bcdf25c46844aa4afc0019af0b507ec8 WHIRLPOOL 475bc50e1db4755997274c39a2a39da1c390f43bccb541a68b0cfe56aba951187d0e68a86415ce466f727e8d8643bab69300711be012cefe52b5cbd562a05d8f
+EBUILD infamousmachine-1.ebuild 1426 SHA256 7e58c6563bc2cc326a73df8b7bfb5ca77bad38ca37b68469ac48cb22f1132d75 SHA512 01576d6590a4c391c1eb92450638dabf7b36e423b2ae0f1f6ab0fa6ec9b5d72fecfe8f4334e64d480813c344cd342c1688fc19b121d1c424bd6d52b9356afc09 WHIRLPOOL 5f9f76769a25fe4971244623798be2f9844534e60da3e3dbce494a53e5daf2c3e73c575658d2b51f48deb7098d9874501f54b7f8b87e737c254389ebd19bf07c
+MISC metadata.xml 733 SHA256 c2ed97c761163a46de509c129b9a6316c080a36b88fcc6d6e4c9dab7bea592f0 SHA512 5e377b097357cd790095b689b928df77d2bfdeb89a4bc38d8cc52d486470c9a019d10143fbbc568effaa94ef166dd0540b5f8835403c428fb5ed567a998b065f WHIRLPOOL 9ee5dfd7d331a963d5da080565f23bc7300d6f679e25cfcdefee13826ddd727262d6b0f1754b606f254cda0b8384789888e1264d986b16d3ec84703856b1ad8e
diff --git a/games-rpg/infamousmachine/infamousmachine-1.ebuild b/games-rpg/infamousmachine/infamousmachine-1.ebuild
new file mode 100644
index 0000000..63e9326
--- /dev/null
+++ b/games-rpg/infamousmachine/infamousmachine-1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="A point-and-click adventure about the well intentioned but not-so-brilliant Kelvin, his workplace crush, a crazy scientist, and a hideous time machine that came to ruin everything."
+HOMEPAGE="http://www.infamousmachine.com"
+SRC_URI="infamousmachine_unix_1_0.sh.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jre-1.7:*
+ virtual/opengl
+ media-libs/openal
+ app-arch/p7zip"
+RDEPEND="${DEPEND}"
+
+RESTRICT="bindist fetch mirror strip"
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI}"
+ einfo "from your personal page in Humble Bundle site"
+ einfo "(http://www.humblebundle.com) and place it in ${DISTDIR}"
+}
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ 7zip x infamousmachine_unix_1_0.sh
+}
+
+src_prepare() {
+ rm infamousmachine_unix_1_0.sh
+ rmdir '.install4j\'
+}
+
+src_install() {
+ local dir="/opt/${P}"
+
+ insinto "${dir}"
+ doins InfamousMachine.vmoptions
+ doins InfamousMachine.jar
+ doins .install4j
+
+ exeinto "${dir}"
+ doexe InfamousMachine
+
+ make_wrapper ${PN} ./InfamousMachine "${dir}" "${dir}"
+ newicon .install4j/InfamousMachine.png "${PN}"
+ make_desktop_entry ${PN} "Kelvin and the Infamous Machine" "${PN}" Game
+
+}
+
+
diff --git a/games-rpg/infamousmachine/metadata.xml b/games-rpg/infamousmachine/metadata.xml
new file mode 100644
index 0000000..c082031
--- /dev/null
+++ b/games-rpg/infamousmachine/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>phil_miess@yahoo.com</email>
+<name>Philip Miess</name>
+</maintainer>
+<longdescription lang="en">
+Enraged after his life’s research is ridiculed by the media, Dr. Edwin Lupin decides to become not the greatest genius ever, but the only genius ever, by stealing credit for humankind's most appreciated works.
+
+Now, spacetime is being altered and humanity needs a hero. Can the bumbling Kelvin, driven by a basic understanding of right and wrong, repair the unraveling timeline? Or will he totally blow it and doom the universe to oblivion?
+</longdescription>
+</pkgmetadata>