summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/rhvoice/rhvoice-9999.ebuild')
-rw-r--r--app-accessibility/rhvoice/rhvoice-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-accessibility/rhvoice/rhvoice-9999.ebuild b/app-accessibility/rhvoice/rhvoice-9999.ebuild
index 0eb4243..f4cbf23 100644
--- a/app-accessibility/rhvoice/rhvoice-9999.ebuild
+++ b/app-accessibility/rhvoice/rhvoice-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/iulib/iulib-0.4.ebuild,v 1.7 2012/06/03 02:42:24 vapier Exp $
-EAPI="4"
+EAPI="5"
inherit scons-utils eutils toolchain-funcs multilib git-2
@@ -13,7 +13,7 @@ EGIT_REPO_URI="git://github.com/Olga-Yakovleva/RHVoice.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="rewrite"
RDEPEND=""
DEPEND="${RDEPEND}
@@ -25,6 +25,11 @@ DEPEND="${RDEPEND}
media-sound/sox
dev-util/scons"
+src_unpack() {
+ use rewrite && EGIT_BRANCH="rewrite"
+ git-2_src_unpack;
+}
+
src_compile() {
escons prefix=/usr sysconfdir=/etc
}