summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/corewars/corewars-0.9.13-r1.ebuild')
-rw-r--r--games-simulation/corewars/corewars-0.9.13-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-simulation/corewars/corewars-0.9.13-r1.ebuild b/games-simulation/corewars/corewars-0.9.13-r1.ebuild
new file mode 100644
index 0000000..33b1342
--- /dev/null
+++ b/games-simulation/corewars/corewars-0.9.13-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/corewars/corewars-0.9.13-r1.ebuild,v 1.7 2006/02/22 21:53:28 tupone Exp $
+
+EAPI="5"
+
+inherit games
+
+DESCRIPTION="Simulation game involving virtual machine code"
+HOMEPAGE="http://corewars.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ http://sourceforge.net/p/corewars/patches/_discuss/thread/947a192c/b4cd/attachment/${PN}-gtk2.patch.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${DISTDIR}"/${PN}-gtk2.patch.gz
+ epatch "${FILESDIR}"/${PV}-corewars-lm.patch
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README doc/{TODO,DIFFERENCES,INTERESTING-COMBINATIONS}
+ prepgamesdirs
+}