summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/netvfy/files')
-rw-r--r--net-misc/netvfy/files/netvfy-agent.conf6
-rw-r--r--net-misc/netvfy/files/netvfy-agent.rc14
-rw-r--r--net-misc/netvfy/files/netvfy-agent.service12
-rw-r--r--net-misc/netvfy/files/netvfy-agent.service.conf10
4 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/netvfy/files/netvfy-agent.conf b/net-misc/netvfy/files/netvfy-agent.conf
new file mode 100644
index 0000000..94ebb01
--- /dev/null
+++ b/net-misc/netvfy/files/netvfy-agent.conf
@@ -0,0 +1,6 @@
+# Config file for /etc/init.d/netvfy-agent
+
+# Specify the netvirt network name you want to connect to.
+# **NOTE** For a list see: netvfy-agent -l
+#
+NETWORK_NAME=""
diff --git a/net-misc/netvfy/files/netvfy-agent.rc b/net-misc/netvfy/files/netvfy-agent.rc
new file mode 100644
index 0000000..75bca14
--- /dev/null
+++ b/net-misc/netvfy/files/netvfy-agent.rc
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="start a daemon to maintain a virtual connection using netvfy"
+
+command="netvfy-agent -c ${NETWORK_NAME}"
+command_background="true"
+pidfile="/var/run/${SVCNAME}.pid"
+
+depend() {
+ use net
+}
diff --git a/net-misc/netvfy/files/netvfy-agent.service b/net-misc/netvfy/files/netvfy-agent.service
new file mode 100644
index 0000000..2e045e6
--- /dev/null
+++ b/net-misc/netvfy/files/netvfy-agent.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Netvfy Agent
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/netvfy-agent -c ${NETWORK_NAME}
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/netvfy/files/netvfy-agent.service.conf b/net-misc/netvfy/files/netvfy-agent.service.conf
new file mode 100644
index 0000000..fdce90f
--- /dev/null
+++ b/net-misc/netvfy/files/netvfy-agent.service.conf
@@ -0,0 +1,10 @@
+# Config file for netvfy-agent
+
+# Specify the netvirt network name you want to connect to.
+# **NOTE** For a list see: netvfy-agent -l
+
+[Service]
+# if a user different from root should be use see
+# https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=netvfy-agent-git
+Environment="HOME=/root"
+Environment="NETWORK_NAME="