summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@ndyk.de>2017-02-13 15:45:06 +0100
committerandy <andy@ndyk.de>2017-02-13 15:45:06 +0100
commitc5c1e68fda5e45a7e862b6cb91d58b205c3c367f (patch)
tree3217f40d4b2c0cd346bd99b98d96bbd2eab08696
parentgopass: 1.0.1 bump (diff)
downloadandy-c5c1e68fda5e45a7e862b6cb91d58b205c3c367f.tar.gz
andy-c5c1e68fda5e45a7e862b6cb91d58b205c3c367f.tar.bz2
andy-c5c1e68fda5e45a7e862b6cb91d58b205c3c367f.zip
removed gopass 1.0.0
-rw-r--r--app-admin/gopass/gopass-1.0.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/app-admin/gopass/gopass-1.0.0.ebuild b/app-admin/gopass/gopass-1.0.0.ebuild
deleted file mode 100644
index 014f262..0000000
--- a/app-admin/gopass/gopass-1.0.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit bash-completion-r1
-
-EGO_PN=github.com/justwatchcom/${PN}
-
-if [[ ${PV} == 9999 ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64 ~x86 ~arm"
- EGIT_COMMIT="v${PV}"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="The team password manager. Written in Go."
-HOMEPAGE="https://www.justwatch.com/gopass"
-LICENSE="MIT"
-SLOT="0"
-IUSE="X zsh-completion test"
-DEPEND=">=dev-lang/go-1.6:="
-RDEPEND="
- app-crypt/gnupg
- X? ( x11-misc/xclip )
- zsh-completion? ( app-shells/gentoo-zsh-completions )
- dev-vcs/git
-"
-
-src_compile() {
- cd "${S}"/src/${EGO_PN} || die
- GOPATH="${S}" LDFLAGS="" emake build || die
-}
-
-src_install() {
- cd "${S}"/src/${EGO_PN} || die
- emake DESTDIR="${D}" install
- if use zsh-completion; then
- emake zsh.completion || die
- insinto /usr/share/zsh/site-functions
- newins zsh.completion _${PN}
- fi
- emake bash.completion || die
- newbashcomp bash.completion ${PN}
- einstalldocs
-}
-