summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClaudio Furrer <elcaio@gmail.com>2011-11-24 13:10:27 -0300
committerClaudio Furrer <elcaio@gmail.com>2011-11-24 13:10:27 -0300
commit6316adf564ba973837e8fdf2c4f906b2cadee233 (patch)
tree9cfebc211e002be2bda175623496a100285c84ed
parentAdded fonuator redfone configuration utility. (diff)
downloadcaio-6316adf564ba973837e8fdf2c4f906b2cadee233.tar.gz
caio-6316adf564ba973837e8fdf2c4f906b2cadee233.tar.bz2
caio-6316adf564ba973837e8fdf2c4f906b2cadee233.zip
Addded Siremis, the Web Management Interface for Kamailio.
-rw-r--r--www-apps/siremis/Manifest3
-rw-r--r--www-apps/siremis/files/httpd-wme.conf18
-rw-r--r--www-apps/siremis/siremis-2.0.0.ebuild63
3 files changed, 84 insertions, 0 deletions
diff --git a/www-apps/siremis/Manifest b/www-apps/siremis/Manifest
new file mode 100644
index 0000000..4014981
--- /dev/null
+++ b/www-apps/siremis/Manifest
@@ -0,0 +1,3 @@
+AUX httpd-wme.conf 677 RMD160 ee2813f64e98d8fa4c09364db4f70c1ee544f51c SHA1 ae582c3021730933e544fb14276a93653208a32d SHA256 00047a18838d667b7b55522d4bd7bbe7c4a030fe13432e117490c53dceab7981
+DIST siremis-2.0.0.tgz 10380235 RMD160 fcceab8545ffd1c1f949f0b64432bdb185671cc1 SHA1 36edd00c97915f163e6603be9d8486bc2d6f1c8e SHA256 e77182816a9804e39198d308cd8117a2c0e045aa9ff37730f4f2a4329c2d4cbc
+EBUILD siremis-2.0.0.ebuild 1565 RMD160 1715b6776b72a733ac3e5e97de7eec989bce46c6 SHA1 78171fa2039156c5e221d5a80c0c35038288ea54 SHA256 274f0fe334d058e61c70c849659f4a3fbb8b0a89b9ccb77989994cfcb2ac9397
diff --git a/www-apps/siremis/files/httpd-wme.conf b/www-apps/siremis/files/httpd-wme.conf
new file mode 100644
index 0000000..9ca5e27
--- /dev/null
+++ b/www-apps/siremis/files/httpd-wme.conf
@@ -0,0 +1,18 @@
+<VirtualHost *:80>
+ ServerName siremis.mydomain.com
+ #ServerAlias wme.mydomain.com
+ Alias /siremis/ "/var/www/siremis.mydomain.com/htdocs/siremis/"
+ DocumentRoot /var/www/siremis.mydomain.com/htdocs/siremis
+ <Directory "/var/www/siremis.mydomain.com/htdocs/siremis">
+ Options Indexes FollowSymLinks MultiViews
+ AllowOverride All
+ Order allow,deny
+ Allow from all
+ RedirectMatch ^/siremis/$ /siremis/bin/
+ <Files ~ "\.inc$">
+ Order allow,deny
+ Deny from all
+ </Files>
+ </Directory>
+ ErrorLog /var/log/apache2/siremis-error.log
+ CustomLog /var/log/apache2/siremis-access.log combined
diff --git a/www-apps/siremis/siremis-2.0.0.ebuild b/www-apps/siremis/siremis-2.0.0.ebuild
new file mode 100644
index 0000000..8c63c7a
--- /dev/null
+++ b/www-apps/siremis/siremis-2.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils webapp depend.php depend.apache
+
+MY_P="${PF//}"
+
+DESCRIPTION="WiPLExME (based on Siremis) is a web interface for provisioning of users of WiPLEx SIP Server."
+HOMEPAGE="http://siremis.asipto.com/"
+SRC_URI="http://siremis.asipto.com/pub/downloads/siremis/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/httpd-php-5.0"
+
+need_php_httpd
+need_apache
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup () {
+ webapp_pkg_setup
+ use mysql && require_php_with_use mysql zlib xml
+}
+
+src_install() {
+ webapp_src_preinst # cp -R * ${D}/${MY_HTDOCSDIR}
+
+ dodoc ChangeLog README || die
+ rm -rf ChangeLog README
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files="siremis siremis/log siremis/session siremis/files"
+ #siremis/templates/cpl
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/siremis/Config.xml
+ webapp_configfile "${MY_HTDOCSDIR}"/openbiz/metadata/Config.xml
+
+ #webapp_configfile "${APACHE_VHOSTS_CONFDIR}"/httpd-wme.conf
+ insinto "${APACHE_VHOSTS_CONFDIR}"
+ doins "${FILESDIR}/httpd-wme.conf" || die
+
+ #webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn "webapp-config will not be run automatically"
+ ewarn "Try to run webapp-config this way:"
+ ewarn "webapp-config -I -h <host> -d siremis ${PN} ${PVR}"
+ # webapp_pkg_postinst
+ ewarn
+ #ewarn "Follow the instructions in POST-INSTALL."
+}