summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/dswm/dswm-0.0.5-r2.ebuild')
-rw-r--r--x11-wm/dswm/dswm-0.0.5-r2.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/x11-wm/dswm/dswm-0.0.5-r2.ebuild b/x11-wm/dswm/dswm-0.0.5-r2.ebuild
index 2edc45b..ab1117a 100644
--- a/x11-wm/dswm/dswm-0.0.5-r2.ebuild
+++ b/x11-wm/dswm/dswm-0.0.5-r2.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-wm/dswm/dswm-0.0.3.ebuild,v 1.2 2011/04/25 20:36:20 betelgeuse Exp $
+# FIXME: depends on lisp overlay
+
EAPI="2"
inherit common-lisp autotools eutils
@@ -26,8 +28,8 @@ RDEPEND="x11-base/xorg-server
emacs? ( app-emacs/slime )"
src_prepare() {
- mv ${P}/* .
- rm -rf ${P}/
+ mv ${P}r2/* .
+ rm -rf ${P}r2/
eautoconf
}
@@ -41,6 +43,7 @@ src_configure() {
}
src_compile() {
+ mkdir $HOME/.dswm.d # FIXME: will be fixed in dswm
emake
use doc && makeinfo dswm.texi
}
@@ -48,6 +51,7 @@ src_compile() {
src_install() {
common-lisp-install *.lisp dswm.asd
common-lisp-system-symlink
+ mkdir -p ${D}/usr/share/xsessions # FIXME: hack
emake destdir=${D} install
dodoc README NEWS ChangeLog "${FILESDIR}/README.Gentoo" || die
use doc && doinfo dswm.info