summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@howl.(none)>2008-06-10 00:22:34 -0400
committerroot <root@howl.(none)>2008-06-10 00:22:34 -0400
commit551df7c47a3196ef4d330fc8c3fee458bd24f447 (patch)
tree13207d2db2c3824a78008f104f6d2f0797ef7939 /games-emulation
parentAdd zerogs svn ebuild. (diff)
downloadeatnumber1-551df7c47a3196ef4d330fc8c3fee458bd24f447.tar.gz
eatnumber1-551df7c47a3196ef4d330fc8c3fee458bd24f447.tar.bz2
eatnumber1-551df7c47a3196ef4d330fc8c3fee458bd24f447.zip
Add zeropad svn ebuild.
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/ps2emu-zeropad/files/ps2emu-zeropad-consistent-naming.patch13
-rw-r--r--games-emulation/ps2emu-zeropad/ps2emu-zeropad-9999.ebuild47
2 files changed, 60 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-zeropad/files/ps2emu-zeropad-consistent-naming.patch b/games-emulation/ps2emu-zeropad/files/ps2emu-zeropad-consistent-naming.patch
new file mode 100644
index 0000000..834d811
--- /dev/null
+++ b/games-emulation/ps2emu-zeropad/files/ps2emu-zeropad-consistent-naming.patch
@@ -0,0 +1,13 @@
+--- zeropad/Makefile.am.orig 2008-06-08 22:29:35.000000000 -0400
++++ zeropad/Makefile.am 2008-06-08 22:29:45.000000000 -0400
+@@ -13,10 +13,6 @@
+ # Create a shared object by faking an exe (thanks to ODE makefiles)
+ traplibdir=$(prefix)
+
+-if DEBUGBUILD
+-preext=d
+-endif
+-
+ EXEEXT=$(preext)@so_ext@
+
+ traplib_PROGRAMS=libZeroPAD
diff --git a/games-emulation/ps2emu-zeropad/ps2emu-zeropad-9999.ebuild b/games-emulation/ps2emu-zeropad/ps2emu-zeropad-9999.ebuild
new file mode 100644
index 0000000..8459546
--- /dev/null
+++ b/games-emulation/ps2emu-zeropad/ps2emu-zeropad-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ESVN_REPO_URI="https://pcsx2.svn.sourceforge.net/svnroot/pcsx2/plugins/pad/zeropad"
+inherit eutils games subversion autotools
+
+DESCRIPTION="PS2Emu pad plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/zeropad"
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-consistent-naming.patch"
+
+ sed -r -i \
+ -e '/C(..)?FLAGS=/d' \
+ -e 's/-O[0-9]\b//g' \
+ -e 's/-fomit-frame-pointer\b//g' \
+ -e 's/C(..)?FLAGS\+="/C\1FLAGS+=" /' \
+ configure.ac || die
+
+ eautoreconf -v --install || die
+}
+
+src_compile() {
+ egamesconf $(use_enable debug) || die
+ emake || die
+}
+
+src_install() {
+ exeinto "$(games_get_libdir)/ps2emu/plugins"
+ doexe libZeroPAD.so.* || die
+ prepgamesdirs
+}