summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@howl.(none)>2008-06-10 00:15:06 -0400
committerroot <root@howl.(none)>2008-06-10 00:15:06 -0400
commit7affd04c32abdde0617e00a2bfd1d31afd1f7997 (patch)
tree6e226b59186f8ac56eab426fe2b689510ab0b2c7 /games-emulation
parentCreated a pcsx2 subversion ebuild. (diff)
downloadeatnumber1-7affd04c32abdde0617e00a2bfd1d31afd1f7997.tar.gz
eatnumber1-7affd04c32abdde0617e00a2bfd1d31afd1f7997.tar.bz2
eatnumber1-7affd04c32abdde0617e00a2bfd1d31afd1f7997.zip
Add cdvdnull svn ebuild
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/ps2emu-cdvdnull/ps2emu-cdvdnull-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-cdvdnull/ps2emu-cdvdnull-9999.ebuild b/games-emulation/ps2emu-cdvdnull/ps2emu-cdvdnull-9999.ebuild
new file mode 100644
index 0000000..871efde
--- /dev/null
+++ b/games-emulation/ps2emu-cdvdnull/ps2emu-cdvdnull-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ESVN_REPO_URI="https://pcsx2.svn.sourceforge.net/svnroot/pcsx2/plugins/cdvd/CDVDnull"
+inherit eutils games subversion
+
+DESCRIPTION="PS2Emu null CDVD plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/CDVDnull"
+
+src_unpack() {
+ subversion_src_unpack
+ S="${S}/Src"
+ cd "${S}"
+
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/\${STRIP}/d' \
+ -e 's/-O[0-9]\b//g' \
+ -e 's/-fomit-frame-pointer\b//g' \
+ -e 's/-ffast-math\b//g' \
+ -e "s/^OPTIMIZE = /OPTIMIZE = ${CFLAGS} /" \
+ Makefile || die
+}
+
+src_install() {
+ exeinto "$(games_get_libdir)/ps2emu/plugins"
+ doexe libCDVDnull.so || die
+ use doc && dodoc ../ReadMe.txt || die
+ prepgamesdirs
+}