summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2009-12-31 10:41:25 -0500
committerRussell Harmon <russ@eatnumber1.com>2009-12-31 11:20:02 -0500
commit6d8c508f0b4a2c3607fc5855cb46e9f9229aaac3 (patch)
tree7b03dcf4f6c7b279dc6f1bf8557eece6c6ae0e29 /x11-misc
parentRemoved keynav since it's in sunrise. (diff)
downloadeatnumber1-6d8c508f0b4a2c3607fc5855cb46e9f9229aaac3.tar.gz
eatnumber1-6d8c508f0b4a2c3607fc5855cb46e9f9229aaac3.tar.bz2
eatnumber1-6d8c508f0b4a2c3607fc5855cb46e9f9229aaac3.zip
Add xdotool-20091231.01 ebuild.
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xdotool/Manifest3
-rw-r--r--x11-misc/xdotool/files/xdotool-20091231.01_install-D.patch40
-rw-r--r--x11-misc/xdotool/xdotool-20091231.01.ebuild40
3 files changed, 83 insertions, 0 deletions
diff --git a/x11-misc/xdotool/Manifest b/x11-misc/xdotool/Manifest
new file mode 100644
index 0000000..53a33ee
--- /dev/null
+++ b/x11-misc/xdotool/Manifest
@@ -0,0 +1,3 @@
+AUX xdotool-20091231.01_install-D.patch 1181 RMD160 0b969762447a88252737a990b40ecf8f2384e93b SHA1 d7b370c87a2496e6bfc2638269e58754b9729355 SHA256 d83f97b9f3bfb55ea841fbecdf1e5267978492d08d0fe207d41e53b52cd1ae91
+EBUILD xdotool-20091231.01.ebuild 1000 RMD160 5d8dcc88d3be3bb15b0d9e16fb011715cd2b6c76 SHA1 c5a9de7ba04407239485c96c4edaca28f7741e4c SHA256 ddc5c79df27d11c356e59abeb992f3839e367f2e840611983625c040543e12a9
+DIST xdotool-20091231.01.tar.gz 23913 RMD160 ac567df0b8a2b6bbb9cb9b87bbe8f735592c276d SHA1 6f0b2404b2fa477bfb28f1cf437250e0a54308b9 SHA256 d880ee63a9bbf59c6d1e269987729594fd85003ffa08cf92b7c26d8ce762e0c2
diff --git a/x11-misc/xdotool/files/xdotool-20091231.01_install-D.patch b/x11-misc/xdotool/files/xdotool-20091231.01_install-D.patch
new file mode 100644
index 0000000..acc6ce7
--- /dev/null
+++ b/x11-misc/xdotool/files/xdotool-20091231.01_install-D.patch
@@ -0,0 +1,40 @@
+From 3ca62c68ae4d46ce88327ca54b12a8954d72c836 Mon Sep 17 00:00:00 2001
+From: Russell Harmon <russ@eatnumber1.com>
+Date: Thu, 31 Dec 2009 11:00:25 -0500
+Subject: [PATCH] Use -D when installing to create directories.
+
+---
+ Makefile | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 308a5d5..e1d755f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -29,19 +29,19 @@ all: xdotool xdotool.1
+ install: installlib installprog installman installheader
+
+ installprog: xdotool
+- install -m 755 xdotool $(INSTALLBIN)/
++ install -D -m 755 xdotool $(INSTALLBIN)/xdotool
+
+ installlib: libxdo.so
+- install libxdo.so $(INSTALLLIB)/libxdo.so.$(MINOR)
++ install -D libxdo.so $(INSTALLLIB)/libxdo.so.$(MINOR)
+ ln -sf libxdo.so.$(MINOR) $(INSTALLLIB)/libxdo.so
+
+ installheader: xdo.h
+- install xdo.h $(INSTALLINCLUDE)/xdo.h
++ install -D xdo.h $(INSTALLINCLUDE)/xdo.h
+
+ installman: xdotool.1
+ [ -d $(INSTALLMAN) ] || mkdir $(INSTALLMAN)
+ [ -d $(INSTALLMAN)/man1 ] || mkdir $(INSTALLMAN)/man1
+- install -m 644 xdotool.1 $(INSTALLMAN)/man1/
++ install -D -m 644 xdotool.1 $(INSTALLMAN)/man1/xdotool.1
+
+ deinstall: uninstall
+ uninstall:
+--
+1.6.4.4
+
diff --git a/x11-misc/xdotool/xdotool-20091231.01.ebuild b/x11-misc/xdotool/xdotool-20091231.01.ebuild
new file mode 100644
index 0000000..b7876aa
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-20091231.01.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-20090815.ebuild,v 1.1 2009/10/21 10:17:23 joker Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic multilib
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows."
+HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
+SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+DEPEND="x11-libs/libXtst
+ x11-libs/libX11"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_install-D.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+ emake LD="$(tc-getLD)" LDFLAGS="$(raw-ldflags)" libxdo.so || die
+}
+
+src_install() {
+ emake PREFIX="${D}usr" INSTALLLIB="${D}usr/$(get_libdir)" install || die
+
+ dodoc CHANGELIST README
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}