summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/compcache-tools/compcache-tools-0.6.ebuild')
-rw-r--r--sys-block/compcache-tools/compcache-tools-0.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-block/compcache-tools/compcache-tools-0.6.ebuild b/sys-block/compcache-tools/compcache-tools-0.6.ebuild
new file mode 100644
index 0000000..98e0703
--- /dev/null
+++ b/sys-block/compcache-tools/compcache-tools-0.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+MY_P="${P/-tools/}"
+DESCRIPTION="Compressed in-memory swap device for Linux"
+HOMEPAGE="http://code.google.com/p/compcache/"
+SRC_URI="http://compcache.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}/sub-projects/rzscontrol"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_gentoo.patch"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin rzscontrol || die
+ doman man/rzscontrol.1 || die
+}