aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Fish <gentoo@seaofdirac.net>2018-07-01 20:13:25 +0200
committerNicholas Fish <gentoo@seaofdirac.net>2018-07-01 20:13:25 +0200
commit9d14a1d91e8a0e76c7161f72e9f784ec1bd08424 (patch)
tree634efd7a243c1b0e7fe45ca264f160c0b248a1fc /app-crypt/sbsigntool/sbsigntool-0.9.1-r1.ebuild
parentmedia-libs/mesa: version bump to 18.1.1, update ebuild to match Gentoo in-tree (diff)
downloadennui-9d14a1d91e8a0e76c7161f72e9f784ec1bd08424.tar.gz
ennui-9d14a1d91e8a0e76c7161f72e9f784ec1bd08424.tar.bz2
ennui-9d14a1d91e8a0e76c7161f72e9f784ec1bd08424.zip
app-crypt/sbsigntool(s): add back support for LibreSSL in addition to OpenSSL >= 1.1.0
Diffstat (limited to 'app-crypt/sbsigntool/sbsigntool-0.9.1-r1.ebuild')
-rw-r--r--app-crypt/sbsigntool/sbsigntool-0.9.1-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/sbsigntool/sbsigntool-0.9.1-r1.ebuild b/app-crypt/sbsigntool/sbsigntool-0.9.1-r1.ebuild
new file mode 100644
index 0000000..7bb20f1
--- /dev/null
+++ b/app-crypt/sbsigntool/sbsigntool-0.9.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils autotools
+
+DESCRIPTION="Utilities for signing and verifying files for UEFI Secure Boot"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jejb/sbsigntools.git/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jejb/${PN}s.git/snapshot/${PN}s-${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~tamiko/distfiles/${PN}-0.8-ccan.tar.gz"
+
+LICENSE="GPL-3 LGPL-3 LGPL-2.1 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-apps/util-linux"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ sys-boot/gnu-efi
+ sys-libs/binutils-libs
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}s-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-openssl-1.1.0-libressl-compat.patch
+)
+
+src_prepare() {
+ mv "${WORKDIR}"/lib/ccan "${S}"/lib || die "mv failed"
+ rmdir "${WORKDIR}"/lib || die "rmdir failed"
+
+ local iarch
+ case ${ARCH} in
+ amd64) iarch=x86_64 ;;
+ arm64) iarch=aarch64 ;;
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ *) die "unsupported architecture: ${ARCH}" ;;
+ esac
+ sed -i "/^EFI_ARCH=/s:=.*:=${iarch}:" configure.ac || die
+ sed -i 's/-m64$/& -march=x86-64/' tests/Makefile.am || die
+ sed -i "/^AR /s:=.*:= $(tc-getAR):" lib/ccan/Makefile.in || die #481480
+
+ default
+ eautoreconf
+}