summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen-overlay@occam.eroen.eu>2017-07-15 21:21:35 +0200
committereroen <eroen-overlay@occam.eroen.eu>2017-07-15 21:21:35 +0200
commit4d27ca5318bcfa7d637249c9d8c96b521421c991 (patch)
treedf6c15acf9486d17bf4572c2f11e0cf78ef07543
parentdfhack - hackily enable ruby22 (diff)
downloaderoen-4d27ca5318bcfa7d637249c9d8c96b521421c991.tar.gz
eroen-4d27ca5318bcfa7d637249c9d8c96b521421c991.tar.bz2
eroen-4d27ca5318bcfa7d637249c9d8c96b521421c991.zip
vte-0.46.2 - bump
-rw-r--r--x11-libs/vte/Manifest1
-rw-r--r--x11-libs/vte/metadata.xml14
-rw-r--r--x11-libs/vte/vte-0.46.2.ebuild81
3 files changed, 90 insertions, 6 deletions
diff --git a/x11-libs/vte/Manifest b/x11-libs/vte/Manifest
index 0724351..94fb5d8 100644
--- a/x11-libs/vte/Manifest
+++ b/x11-libs/vte/Manifest
@@ -5,3 +5,4 @@ DIST vte-0.40.2.tar.xz 923852 SHA256 9b68fbc16b27f2d79e6271f2b0708808594ac5acf97
DIST vte-0.42.4.tar.xz 928048 SHA256 08c88bf5c0aa1dfa3711e2e83b784fb5ea82025661f30b54e93eebd5f4bce113 SHA512 871b47d976ae8faafabd2b9dd092b40b2b452fcfd7f60182db7c12ade0c265a1810e811a9a54b6a2c2061ff05f06743b90057babf300b98f391481bb02265fb5 WHIRLPOOL e3e9fbf5303770244b10259f1a07e41a7c0168debda2e81673f8fa1e19f591a4d2c643f614636e691ecaf22fc00eb8fce79d9d4a8d20c899f5a7e4ac187259db
DIST vte-0.44.2.tar.xz 974596 SHA256 a1ea594814bb136a3a9a6c7656b46240571f6a198825c1111007fe99194b0949 SHA512 98db3c1528d5f458164e2d30056cd816e5943d9c569551878119e79d4fbca1865e52667393bf298f32fd54710d1b268a5aac125222ecb29ce854522be3776356 WHIRLPOOL 62830dc20a3aa29f4c13b3370d960f5522bb42231b68f426b2b662a40c4c8265f9d8a76c4e598cdfd5c8d8c5f712d3d9828f5f2ed5e24182f9be8697debe2ca6
DIST vte-0.46.1.tar.xz 989164 SHA256 8800cf8bc259704a12ad1853fb0eb43bfe3857af15242e6fb9f2c3fd95b3f5c6 SHA512 04b3f8ce922c4326d92bef605a0dbe195764946cd5f1acf28fd6d69c0cdb2ee661cc7e424436c72380da5d0250790ae658ac49d761b567dea88d92157285889d WHIRLPOOL 7947982c2e9eba1481f302da8bf3433156490537c9e7ab1ef8da8d399b3dccec0911253b8973712be77fa89f7eb9451e09b65ffd6cc2ccc6e2bea9fb9f2997f8
+DIST vte-0.46.2.tar.xz 989756 SHA256 cad246b336e8a20855bf130348ad996ddd28489444128647f9cfc901d9c0cc0f SHA512 abcf94752094314b01eb14156e894bedb24f959d4faf84bb070b34eb2745f01d029859ef959ddf1475776605a1721e4d011ae7ad57fc4937d8bfcbecc8b0cf61 WHIRLPOOL 1b700708fb0eb0ca148d72aaa7d761e0fef962d4c59cb65b8fb295c5dff5c5e206e91f6afcc058b74b726967e1c3c4034b572e36558840b9f4d05952e9c737cb
diff --git a/x11-libs/vte/metadata.xml b/x11-libs/vte/metadata.xml
index 0a00f89..f28117e 100644
--- a/x11-libs/vte/metadata.xml
+++ b/x11-libs/vte/metadata.xml
@@ -1,10 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<use>
- <flag name='glade'>Provide integration with <pkg>dev-util/glade</pkg>.</flag>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for
- introspection</flag>
- <flag name="termite-patch">Apply patch for <pkg>x11-terms/termite</pkg></flag>
-</use>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="glade">Provide integration with <pkg>dev-util/glade</pkg>.</flag>
+ <flag name="termite-patch">Apply patch for <pkg>x11-terms/termite</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/x11-libs/vte/vte-0.46.2.ebuild b/x11-libs/vte/vte-0.46.2.ebuild
new file mode 100644
index 0000000..d3e79f4
--- /dev/null
+++ b/x11-libs/vte/vte-0.46.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 vala
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE termite-patch? ( https://github.com/thestinger/vte-ng )"
+
+LICENSE="LGPL-2+"
+SLOT="2.91"
+IUSE="+crypt debug glade +introspection termite-patch vala"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=dev-libs/libpcre2-10.21
+ >=x11-libs/gtk+-3.8:3[introspection?]
+ >=x11-libs/pango-1.22.0
+
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+
+ crypt? ( >=net-libs/gnutls-3.2.7 )
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ vala? ( $(vala_depend) )
+"
+RDEPEND="${RDEPEND}
+ !x11-libs/vte:2.90[glade]
+"
+
+src_prepare() {
+ use termite-patch && eapply "$FILESDIR"/vte-ng-0.46.0.patch
+ use vala && vala_src_prepare
+
+ # build fails because of -Werror with gcc-5.x
+ sed -e 's#-Werror=format=2#-Wformat=2#' -i configure || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ myconf="${myconf} --disable-Bsymbolic"
+
+ # interix stropts.h is empty...
+ export ac_cv_header_stropts_h=no
+ fi
+
+ # Python bindings are via gobject-introspection
+ # Ex: from gi.repository import Vte
+ gnome2_src_configure \
+ --disable-test-application \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable glade glade-catalogue) \
+ $(use_with crypt gnutls) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ ${myconf}
+}
+
+src_install() {
+ gnome2_src_install
+ mv "${D}"/etc/profile.d/vte{,-${SLOT}}.sh || die
+}