summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen@falcon.eroen.eu>2014-04-05 21:54:37 +0200
committereroen <eroen@falcon.eroen.eu>2014-04-06 19:20:47 +0200
commit6d14daf26f1f43ef5ede5bf9c5eb754e430fb2e3 (patch)
treef0eec0694545eb8095f90ab6012b428faf7b61ee /games-roguelike
parentk9copy - fix building with ffmpeg-2 (diff)
downloaderoen-6d14daf26f1f43ef5ede5bf9c5eb754e430fb2e3.tar.gz
eroen-6d14daf26f1f43ef5ede5bf9c5eb754e430fb2e3.tar.bz2
eroen-6d14daf26f1f43ef5ede5bf9c5eb754e430fb2e3.zip
FTL-1.03.3 from gentoo
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/FTL/FTL-1.03.3.ebuild67
-rw-r--r--games-roguelike/FTL/Manifest1
-rw-r--r--games-roguelike/FTL/metadata.xml9
3 files changed, 77 insertions, 0 deletions
diff --git a/games-roguelike/FTL/FTL-1.03.3.ebuild b/games-roguelike/FTL/FTL-1.03.3.ebuild
new file mode 100644
index 0000000..a780477
--- /dev/null
+++ b/games-roguelike/FTL/FTL-1.03.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Faster Than Light: A spaceship simulation real-time roguelike-like game"
+HOMEPAGE="http://www.ftlgame.com/"
+SRC_URI="FTL.Linux.${PV}.tar.gz"
+
+LICENSE="all-rights-reserved Boost-1.0 free-noncomm MIT bundled-libs? ( FTL LGPL-2.1 ZLIB libpng )"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="fetch bindist splitdebug"
+
+RDEPEND="
+ sys-devel/gcc[cxx]
+ virtual/opengl
+ !bundled-libs? (
+ media-libs/devil[png,opengl]
+ media-libs/freetype:2
+ media-libs/libsdl[X,audio,joystick,opengl,video]
+ sys-libs/zlib
+ )"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/bin/${PN}
+ ${GAMES_PREFIX_OPT#/}/${PN}/lib/*"
+
+S=${WORKDIR}/${PN}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_prepare() {
+ if ! use bundled-libs ; then
+ # no system lib for libbass available
+ find data/${ARCH}/lib -type f \! -name "libbass*" -delete || die
+ fi
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r data/resources
+ doins data/exe_icon.bmp
+
+ exeinto "${dir}"/bin
+ doexe data/${ARCH}/bin/${PN}
+ exeinto "${dir}"/lib
+ doexe data/${ARCH}/lib/*.so*
+
+ games_make_wrapper ${PN} "${dir}/bin/${PN}" "${dir}" "${dir}/lib"
+ make_desktop_entry ${PN} "Faster Than Light" "/usr/share/pixmaps/FTL.bmp"
+
+ newicon data/exe_icon.bmp FTL.bmp
+ dohtml ${PN}_README.html
+
+ prepgamesdirs
+}
diff --git a/games-roguelike/FTL/Manifest b/games-roguelike/FTL/Manifest
new file mode 100644
index 0000000..cf87298
--- /dev/null
+++ b/games-roguelike/FTL/Manifest
@@ -0,0 +1 @@
+DIST FTL.Linux.1.03.3.tar.gz 156790275 SHA256 a18983cac8cb0db8990d3b56c301d9983f0a8a5ad4850266922b7c5d538c178d SHA512 91efc51d526eb4e423d89e6b13a0400a75208007ce0fc4a3542634392ee5755256c89a628beb4f15dedc0d19197f29683cbbf4a1652fdc182dac5cd2ecd17b1f WHIRLPOOL fbfa48d9eabf8d6227e50bf5665f9e3563f71d3dce4e92752c1bc7afce9140dbfe0dca16a2ee2d189c95491fffb76eed0f62b049f7674834c4c157dd0a9dd615
diff --git a/games-roguelike/FTL/metadata.xml b/games-roguelike/FTL/metadata.xml
new file mode 100644
index 0000000..c5c7aae
--- /dev/null
+++ b/games-roguelike/FTL/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>Use bundled libraries.</flag>
+ </use>
+</pkgmetadata>
+