summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/openmw/openmw-9999.ebuild')
-rw-r--r--games-engines/openmw/openmw-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/games-engines/openmw/openmw-9999.ebuild b/games-engines/openmw/openmw-9999.ebuild
index ffdbfbb..7b6e19e 100644
--- a/games-engines/openmw/openmw-9999.ebuild
+++ b/games-engines/openmw/openmw-9999.ebuild
@@ -20,7 +20,7 @@ if [[ $(get_version_component_range $(get_version_component_count)) == *999? ]];
EGIT_BRANCH=openmw$(get_version_component_range 2)
fi
else
- SRC_URI="https://github.com/zinnschlag/${PN}/archive/${P}.tar.gz"
+ SRC_URI="https://${PN}.googlecode.com/files/${P}-source.tar.gz"
S="${WORKDIR}"/${PN}-${P}
fi
@@ -37,12 +37,14 @@ OPENCS_LIBS="dev-qt/qtcore
dev-qt/qtxmlpatterns"
HDEPEND=""
+# boost[threads]: can't test https://bugs.gentoo.org/458404
+# libsdl2[-directfb]: https://bugs.gentoo.org/503130
LIBDEPEND="${OPENMW_LIBS}
launcher? ( ${LAUNCHER_LIBS} )
opencs? ( ${OPENCS_LIBS} )
dev-games/ogre[boost,cg,freeimage,opengl,threads,zip]
dev-libs/boost:=[threads]
- media-libs/libsdl2"
+ media-libs/libsdl2[-directfb]"
DEPEND="${LIBDEPEND}
test? ( dev-cpp/gmock[tr1=]
dev-cpp/gtest[tr1=] )"