summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Mavrinac <mavrinac@gmail.com>2011-01-25 20:09:17 -0500
committerAaron Mavrinac <mavrinac@gmail.com>2011-01-25 20:09:17 -0500
commitacaecd161e7bf2776fb74c332b7cf9f9adea6d28 (patch)
tree8b709785b3b7dd2d719bdcd536788568268c20d9 /dev-python
parentAdd dev-python/polygon ebuild. (diff)
downloadezod-acaecd161e7bf2776fb74c332b7cf9f9adea6d28.tar.gz
ezod-acaecd161e7bf2776fb74c332b7cf9f9adea6d28.tar.bz2
ezod-acaecd161e7bf2776fb74c332b7cf9f9adea6d28.zip
Add corrected dev-python/visual ebuild (temporary, hopefully).
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/visual/Manifest1
-rw-r--r--dev-python/visual/visual-5.4-r1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/visual/Manifest b/dev-python/visual/Manifest
new file mode 100644
index 0000000..f363bc8
--- /dev/null
+++ b/dev-python/visual/Manifest
@@ -0,0 +1 @@
+DIST visual-5.4_release.tar.bz2 2695774 RMD160 f16fbd592b483332d4b6330a221e888618ccdcf9 SHA1 81a23b6a46c71bfd3305555a460e59ba7e49633f SHA256 7d32ddc4e6c0fce5be961b200c29cdf8d3f7459157b7bfd6a661cace93728c87
diff --git a/dev-python/visual/visual-5.4-r1.ebuild b/dev-python/visual/visual-5.4-r1.ebuild
new file mode 100644
index 0000000..ecc0205
--- /dev/null
+++ b/dev-python/visual/visual-5.4-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.4.ebuild,v 1.4 2011/01/15 15:41:39 maekke Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit flag-o-matic python versionator
+
+MY_P="${PN}-$(delete_version_separator 2)_release"
+
+DESCRIPTION="Real-time 3D graphics library for Python"
+HOMEPAGE="http://www.vpython.org/"
+SRC_URI="http://www.vpython.org/contents/download/${MY_P}.tar.bz2"
+
+IUSE="doc examples"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+LICENSE="visual"
+
+RDEPEND=">=dev-libs/boost-1.41.0[python]
+ dev-cpp/libglademm
+ >=dev-cpp/gtkglextmm-1.2
+ dev-python/numpy
+ dev-python/polygon
+ >=dev-python/ttfquery-1.0.4
+ dev-python/fonttools"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ echo "#!/bin/bash" > py-compile
+ python_src_prepare
+}
+
+src_configure() {
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.41.0")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ # We have to use a hack here because the build system doesn't provide a way to specify
+ # the include and lib directory for boost.
+ append-cxxflags -I${BOOST_INC}
+ append-ldflags -L${BOOST_LIB}
+
+ python_src_configure \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-example-dir=/usr/share/doc/${PF}/examples \
+ $(use_enable doc docs) \
+ $(use_enable examples)
+}
+
+src_install() {
+ python_src_install
+ python_clean_installation_image
+
+ dodoc authors.txt HACKING.txt NEWS.txt || die "dodoc failed"
+
+ # Don't install useless vpython script.
+ rm -fr "${ED}usr/bin"
+}
+
+pkg_postinst() {
+ python_mod_optimize vis visual
+}
+
+pkg_postrm() {
+ python_mod_cleanup vis visual
+}