aboutsummaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorGregory M. Tuner <gmt@be-evil.net>2014-06-05 02:44:19 -0700
committerGregory M. Tuner <gmt@be-evil.net>2014-06-05 02:44:19 -0700
commit86f90e0ea9b1a7af97d9f3401d42977ac59d2108 (patch)
treeaa1be50fd459362ed7c4b95c1556f0cfda56ccd8 /eclass
parentautotoos-multilib.eclass: sync with upstream (diff)
downloadgmt-86f90e0ea9b1a7af97d9f3401d42977ac59d2108.tar.gz
gmt-86f90e0ea9b1a7af97d9f3401d42977ac59d2108.tar.bz2
gmt-86f90e0ea9b1a7af97d9f3401d42977ac59d2108.zip
eclass/autotools-utils: sync with upstream
Signed-off-by: Gregory M. Tuner <gmt@be-evil.net>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools-utils.eclass104
1 files changed, 10 insertions, 94 deletions
diff --git a/eclass/autotools-utils.eclass b/eclass/autotools-utils.eclass
index 70e3841..b4e4fab 100644
--- a/eclass/autotools-utils.eclass
+++ b/eclass/autotools-utils.eclass
@@ -96,8 +96,9 @@ esac
# @ECLASS-VARIABLE: AUTOTOOLS_AUTORECONF
# @DEFAULT_UNSET
# @DESCRIPTION:
-# Set to a non-empty value in order to enable running autoreconf
-# in src_prepare() and adding autotools dependencies.
+# When set to a non-empty value, autotools-utils.eclass will
+# automatically generate autotools dependencies and run autoreconf
+# during autotools-utils_src_prepare.
#
# This is usually necessary when using live sources or applying patches
# modifying configure.ac or Makefile.am files. Note that in the latter case
@@ -121,17 +122,11 @@ EXPORT_FUNCTIONS src_prepare src_configure src_compile src_install src_test
# @DEFAULT_UNSET
# @DESCRIPTION:
# Build directory, location where all autotools generated files should be
-# placed. For out of source builds it defaults to ${WORKDIR}/${P}_build,
-# if not supplied upon invocation of any autotools-utils phase function.
-# For in-source builds, it is set, unconditionally, upon invocation of
-# any autotools-utils phase function, to the value of the first of the
-# following variables (in order) that is found to be non-empty:
-# ECONF_SOURCE, S.
-#
-# This variable was called AUTOTOOLS_BUILD_DIR formerly.
-# new ebuilds and eclasses should not use it, but if possible,
-# autotools-utils.eclass will respect either the old or the new
-# variable name, emitting a qa warning when the old variable is used.
+# placed. For out of source builds it defaults to ${WORKDIR}/${P}_build.
+#
+# This variable was formerly called AUTOTOOLS_BUILD_DIR. The old name
+# is deprcated, but partially still supported by autotools-utils.eclass
+# (a QA warning will be emitted if it is used).
# @ECLASS-VARIABLE: AUTOTOOLS_IN_SOURCE_BUILD
# @DEFAULT_UNSET
@@ -331,84 +326,6 @@ remove_libtool_files() {
done
}
-# @FUNCTION: autotools-utils_autoreconf
-# @DESCRIPTION:
-# Reconfigure the sources (like gnome-autogen.sh or eautoreconf).
-autotools-utils_autoreconf() {
- debug-print-function ${FUNCNAME} "$@"
-
- eqawarn "The autotools-utils_autoreconf() function was deprecated."
- eqawarn "Please call autotools-utils_src_prepare()"
- eqawarn "with AUTOTOOLS_AUTORECONF set instead."
-
- # Override this func to not require unnecessary eaclocal calls.
- autotools_check_macro() {
- local x
-
- # Add a few additional variants as we don't get expansions.
- [[ ${1} = AC_CONFIG_HEADERS ]] && set -- "${@}" \
- AC_CONFIG_HEADER AM_CONFIG_HEADER
-
- for x; do
- grep -h "^${x}" configure.{ac,in} 2>/dev/null
- done
- }
-
- einfo "Autoreconfiguring '${PWD}' ..."
-
- local auxdir=$(sed -n -e 's/^AC_CONFIG_AUX_DIR(\(.*\))$/\1/p' \
- configure.{ac,in} 2>/dev/null)
- if [[ ${auxdir} ]]; then
- auxdir=${auxdir%%]}
- mkdir -p ${auxdir##[}
- fi
-
- # Support running additional tools like gnome-autogen.sh.
- # Note: you need to add additional depends to the ebuild.
-
- # gettext
- if [[ $(autotools_check_macro AM_GLIB_GNU_GETTEXT) ]]; then
- echo 'no' | autotools_run_tool glib-gettextize --copy --force
- elif [[ $(autotools_check_macro AM_GNU_GETTEXT) ]]; then
- eautopoint --force
- fi
-
- # intltool
- if [[ $(autotools_check_macro AC_PROG_INTLTOOL IT_PROG_INTLTOOL) ]]
- then
- autotools_run_tool intltoolize --copy --automake --force
- fi
-
- # gtk-doc
- if [[ $(autotools_check_macro GTK_DOC_CHECK) ]]; then
- autotools_run_tool gtkdocize --copy
- fi
-
- # gnome-doc
- if [[ $(autotools_check_macro GNOME_DOC_INIT) ]]; then
- autotools_run_tool gnome-doc-prepare --copy --force
- fi
-
- if [[ $(autotools_check_macro AC_PROG_LIBTOOL AM_PROG_LIBTOOL LT_INIT) ]]
- then
- _elibtoolize --copy --force --install
- fi
-
- eaclocal
- eautoconf
- eautoheader
- FROM_EAUTORECONF=sure eautomake
-
- local x
- for x in $(autotools_check_macro_val AC_CONFIG_SUBDIRS); do
- if [[ -d ${x} ]] ; then
- pushd "${x}" >/dev/null || die
- autotools-utils_autoreconf
- popd >/dev/null || die
- fi
- done
-}
-
# @FUNCTION: autotools-utils_src_prepare
# @DESCRIPTION:
# The src_prepare function.
@@ -452,9 +369,8 @@ autotools-utils_src_prepare() {
# Normally, if autotools-utils detects "static-libs" in the use-flags of an ebuild,
# it automatically adds "--enable-static" and "--enable-shared" arguments to the
# configure arguments. If these are unknown to configure, an error message will be
-# issued. One could filter these out from othereconfargs during the
-# autotools-utils-pre_src_prepare ehook but that requires a fair bit of effort;
-# by setting this variable to a non-empty value, the arguments are omitted.
+# issued. Setting this variable to a non-empty value will cause these arguments not
+# to be automatically generated.
# @VARIABLE: myeconfargs
# @DEFAULT_UNSET