summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2020-02-10 13:40:58 +0100
committerhaarp <main.haarp@gmail.com>2020-02-10 13:40:58 +0100
commite4ca321ed60aa4d5eb0e518081c105d8512276f2 (patch)
tree0395338072febe8057a4b05e089baf8d6d4a88d6 /app-editors
parentUpdate ddcui to 0.1.0 (diff)
downloadhaarp-e4ca321ed60aa4d5eb0e518081c105d8512276f2.tar.gz
haarp-e4ca321ed60aa4d5eb0e518081c105d8512276f2.tar.bz2
haarp-e4ca321ed60aa4d5eb0e518081c105d8512276f2.zip
Fix Python thingamajing problem with xed
Signed-off-by: haarp <main.haarp@gmail.com>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xed/Manifest4
-rw-r--r--app-editors/xed/xed-1.8.3.ebuild90
-rw-r--r--app-editors/xed/xed-2.4.2.ebuild14
3 files changed, 9 insertions, 99 deletions
diff --git a/app-editors/xed/Manifest b/app-editors/xed/Manifest
index 89eb8bf..3e4dfcb 100644
--- a/app-editors/xed/Manifest
+++ b/app-editors/xed/Manifest
@@ -1,4 +1,2 @@
-DIST xed-1.8.3.tar.gz 3953436 BLAKE2B 8deca12fb709f3a665b111d7b0f4395b575ce159ee5a69360f266f2f3d83a2da1b3da6cda20dd4d6669e93c99d51dd974fd27975d805cdfc9c907cf8598a195b SHA512 e596e9ead6642e3b5c0798375f39a7f3d4c177edb845ad3b1905f4f3cd71a46b939c0e1ac408daf634f9fb31746ba0ec7e61c073630d1bda7d74396de01102a5
DIST xed-2.4.2.tar.gz 4029991 BLAKE2B b8e745564017d27e7397885fa7cf2e76462660bb7d177dbc1fdd7a74f114334631d56fb2fb6835eff39f96a505eedac815986c3e4aa3d5dc9aea449eac8a74aa SHA512 9e448407b322348228037595f482b92afae8d45f1097d7be9598064053e21f7e515d8baf900bc06daccace0cfcbf71b8d709498f3a000ba47b61574090dac077
-EBUILD xed-1.8.3.ebuild 2062 BLAKE2B ea28221b545deabdfd1b9fa635b462679d892d6710f6989df5b0c5977409187fb1f765be424dc6139d21f4f0855b52603c2f50fdf24ba901e5312859f2b1e1c4 SHA512 fd53ba40313050ef2ae2d3511c52b4b87349b3bb04f9d71105b2a4afd35b937580941c2a91a9985583ce8f99d6483897e2f99438b8c96e1f5888db67dd7c8f2c
-EBUILD xed-2.4.2.ebuild 2033 BLAKE2B 37e828660c845201aa5261d16ceadf30f2652afbc282b9d50470b96e98ac854271404f5b08d5e94c7f68a73657cb5649d20eea94c09d2466a55a80f2aa379d20 SHA512 baaab8222ad70e421397807be9c91632de4989c2d05a8bf9486ecccf8629705b5924f58c403645d393911e86b8a53d1a4b582337607d903991ee1151f549e7df
+EBUILD xed-2.4.2.ebuild 2081 BLAKE2B 1a0ab66c4510db0a0626f0bb7d86fb00414804d6adea17448a527f09bc049751333085ee541e7776b38ee58ce2860f0e4a4b7dd68883799420972ce69c63603b SHA512 130151555a506753ade85a2ac960332ada21742f0e80d5709ce794af733befc90fff6aa24b20c13a7d59a4366cddae4be61132f3df5215bb17b59eb759603cb7
diff --git a/app-editors/xed/xed-1.8.3.ebuild b/app-editors/xed/xed-1.8.3.ebuild
deleted file mode 100644
index 3534f57..0000000
--- a/app-editors/xed/xed-1.8.3.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-GNOME2_LA_PUNT="yes" # plugins are dlopened
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit autotools eutils gnome2 multilib python-single-r1
-
-DESCRIPTION="X-Apps [Text] Editor (Cross-DE, backward-compatible, GTK3, traditional UI)"
-HOMEPAGE="https://github.com/linuxmint/xed"
-SRC_URI="https://github.com/linuxmint/xed/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+ CC-BY-SA-3.0"
-SLOT="0"
-
-IUSE="+python spell test"
-# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
-# we need to fix that
-REQUIRED_USE="python? ( ^^ ( $(python_gen_useflags '*') ) )"
-
-KEYWORDS="~amd64 ~x86"
-
-# X libs are not needed for OSX (aqua)
-COMMON_DEPEND="
- >=dev-libs/libxml2-2.5.0:2
- >=dev-libs/glib-2.44:2[dbus]
- >=x11-libs/gtk+-3.16:3[introspection]
- >=x11-libs/gtksourceview-3.18:3.0[introspection]
- >=dev-libs/libpeas-1.14.1[gtk]
-
- gnome-base/gsettings-desktop-schemas
- gnome-base/gvfs
-
- >=x11-libs/xapps-1.2.2
- x11-libs/libX11
- net-libs/libsoup:2.4
-
- python? (
- ${PYTHON_DEPS}
- dev-python/pycairo[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
- dev-libs/libpeas[${PYTHON_USEDEP}] )
- spell? (
- >=app-text/enchant-1.2:=
- >=app-text/iso-codes-0.35 )
-"
-
-RDEPEND="${COMMON_DEPEND}
- x11-themes/adwaita-icon-theme
-"
-
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.1.2
- app-text/yelp-tools
- dev-libs/libxml2:2
- >=dev-util/gtk-doc-am-1
- >=dev-util/intltool-0.50.1
- dev-util/itstool
- >=sys-devel/gettext-0.18
- virtual/pkgconfig
-"
-
-# yelp-tools, gnome-common needed to eautoreconf
-
-pkg_setup() {
- use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
-}
-
-src_prepare() {
-eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
-
- gnome2_src_configure \
- --enable-gvfs-metadata \
- $(use_enable spell)
-}
-
-src_test() {
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
- GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
-}
-
-src_install() {
- gnome2_src_install
-}
diff --git a/app-editors/xed/xed-2.4.2.ebuild b/app-editors/xed/xed-2.4.2.ebuild
index 8000758..f1f3177 100644
--- a/app-editors/xed/xed-2.4.2.ebuild
+++ b/app-editors/xed/xed-2.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -38,12 +38,14 @@ COMMON_DEPEND="
python? (
${PYTHON_DEPS}
- dev-python/pycairo[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
- dev-libs/libpeas[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_MULTI_USEDEP}]
+ dev-libs/libpeas[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
- spell? (
- app-text/gspell )
+ spell? ( app-text/gspell )
"
RDEPEND="${COMMON_DEPEND}