aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-evolution/django-evolution-9999.ebuild')
-rw-r--r--dev-python/django-evolution/django-evolution-9999.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/django-evolution/django-evolution-9999.ebuild b/dev-python/django-evolution/django-evolution-9999.ebuild
deleted file mode 100644
index d79a52e..0000000
--- a/dev-python/django-evolution/django-evolution-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit subversion distutils eutils
-
-DESCRIPTION="A Django application that will run cron jobs for other django apps"
-HOMEPAGE="http://code.google.com/p/django-evolution/ http://pypi.python.org/pypi/django_evolution/"
-ESVN_REPO_URI="http://django-evolution.googlecode.com/svn/trunk/"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-LICENSE="BSD"
-SLOT="0"
-PYTHON_MODNAME="django_evolution"
-
-RDEPEND=""
-DEPEND="${RDEPEND} >=dev-python/django-1.1.4
- dev-python/setuptools"
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" tests/runtests.py
- }
- python_execute_function testing
-}
-
-src_install() {
- # Rename & remove files to avoid file collisions
- adjust() {
- seta=(run-pyflakes.py runtests.py settings.py)
- setb=(_run-pyflakes.py _runtests.py _settings.py)
- for (( i=0 ; i < 3 ; i++ ))
- do
- mv build-${PYTHON_ABI}/lib/tests/${seta[i]} \
- build-${PYTHON_ABI}/lib/tests/${setb[i]}
- einfo ${seta[x]} "moved" || die
- done
- rm build-${PYTHON_ABI}/lib/tests/__init__.py || die
- }
- python_execute_function adjust
- distutils_src_install
- dodoc docs/*
-}