aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/feedparser/feedparser-9999.ebuild')
-rw-r--r--dev-python/feedparser/feedparser-9999.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/feedparser/feedparser-9999.ebuild b/dev-python/feedparser/feedparser-9999.ebuild
new file mode 100644
index 0000000..946440b
--- /dev/null
+++ b/dev-python/feedparser/feedparser-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_TESTS_RESTRICTED_ABIS="*-jython"
+PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
+
+inherit distutils eutils subversion
+
+ESVN_REPO_URI="http://feedparser.googlecode.com/svn/trunk/"
+DESCRIPTION="Parse RSS and Atom feeds in Python"
+HOMEPAGE="http://code.google.com/p/feedparser/ http://pypi.python.org/pypi/feedparser"
+
+# sgmllib is licensed under PSF-2.
+LICENSE="BSD-2 PSF-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+PYTHON_MODNAME="feedparser.py _feedparser_sgmllib.py"
+
+src_prepare() {
+ mv feedparser/sgmllib3.py feedparser/_feedparser_sgmllib.py || die "Renaming sgmllib3.py failed"
+ epatch "${FILESDIR}/${P}-sgmllib.patch"
+
+ sed -e "/import feedparser/isys.path.insert(0, '../build/lib')" -i feedparser/feedparsertest.py
+
+ distutils_src_prepare
+
+ preparation() {
+ if [[ "${PYTHON_ABI}" == 3.* ]]; then
+ 2to3-${PYTHON_ABI} -nw --no-diffs feedparser/feedparsertest.py
+ else
+ # Avoid SyntaxErrors with Python 2.
+ echo "raise ImportError" > feedparser/_feedparser_sgmllib.py
+ fi
+ }
+ python_execute_function -s preparation
+}
+
+src_test() {
+ testing() {
+ cd feedparser || return 1
+ "$(PYTHON)" feedparsertest.py
+ }
+ python_execute_function -s testing
+}