aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hexer/hexer-0.2.3.ebuild')
-rw-r--r--app-editors/hexer/hexer-0.2.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/hexer/hexer-0.2.3.ebuild b/app-editors/hexer/hexer-0.2.3.ebuild
new file mode 100644
index 0000000..3bebef4
--- /dev/null
+++ b/app-editors/hexer/hexer-0.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Hex editor with vi/ex-style user interface"
+HOMEPAGE="https://devel.ringlet.net/editors/hexer/"
+SRC_URI="https://devel.ringlet.net/editors/${PN}/${P}.tar.gz"
+
+LICENSE="hexer"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin ${PN} bin2c
+ doman ${PN}.1
+ dodoc CHANGES README
+}