summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2012-04-20 12:22:47 -0400
committerJustin Riley <justin.t.riley@gmail.com>2012-04-20 12:22:47 -0400
commited085411a4315e653e7df92c6886b1dfaad0cd4f (patch)
treec637d7b40dde22d7a3cdfb5b57c46e3f7601bd0a
parentstarcluster: remove keywords from 9999 ebuild (diff)
downloadjtriley-ed085411a4315e653e7df92c6886b1dfaad0cd4f.tar.gz
jtriley-ed085411a4315e653e7df92c6886b1dfaad0cd4f.tar.bz2
jtriley-ed085411a4315e653e7df92c6886b1dfaad0cd4f.zip
rb_libtorrent: fix boost bug again for 0.15.9
-rw-r--r--net-libs/rb_libtorrent/Manifest1
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/rb_libtorrent/Manifest b/net-libs/rb_libtorrent/Manifest
index c36138a..4e61b1e 100644
--- a/net-libs/rb_libtorrent/Manifest
+++ b/net-libs/rb_libtorrent/Manifest
@@ -1 +1,2 @@
DIST libtorrent-rasterbar-0.15.6.tar.gz 2608765 SHA256 dc84775911129942d21ed94569f7c06accffcf31dc909b26eca5f824efb63f13 SHA512 b62939fd8e067c536236bc5b96498c65de454eaeb76e23c360c848a523f6b306410164ef90ca2540324f4f6d6be88072903f6002075621e108c26550ad447e2d WHIRLPOOL c72ed103a0a618278e053c741a08f25f3725ba16f88bca469c7e191971455ef3868f2bd7c69468e2fec1bde275f17e3b2c20b9a7c34d382ea0d0ac98adfb139e
+DIST libtorrent-rasterbar-0.15.9.tar.gz 2619950 SHA256 a2ea68011e9933c7deb473268122f016171d24f0f35e744fbdadd14bf6bac23d SHA512 abbf237b03c1ca5ff0022487caea6b533254467dbc3d74450cc000a3c9fca4c88c9589e17f88534fe49e87bd29a179fa964eea821873dcab62ac07cfc6246a40 WHIRLPOOL 7de400e51564273021ca7694335e58c6e8bbe12f2a65208d7ca002def4c32e1ca744d68fb4cf74de31a8cb09d7a914206dcbbc3305ee6b7a78741e94c99b04ea
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild
new file mode 100644
index 0000000..ff1b7c2
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.9.ebuild,v 1.6 2012/04/19 14:40:00 ranger Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? 2:2.6"
+PYTHON_USE_WITH="threads"
+PYTHON_USE_WITH_OPT="python"
+
+inherit eutils multilib python versionator
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="debug doc examples python ssl static-libs"
+RESTRICT="test"
+
+DEPEND="<dev-libs/boost-1.48[python?]
+ >=sys-devel/libtool-2.2
+ sys-libs/zlib
+ examples? ( !net-p2p/mldonkey )
+ ssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use python && python_set_active_version 2
+}
+
+src_prepare() {
+ use python && python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ # use multi-threading versions of boost libs
+ local BOOST_LIBS="--with-boost-system=boost_system-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-python=boost_python-${PYTHON_ABI}-mt"
+ # detect boost version and location, bug 295474
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ local LOGGING
+ use debug && LOGGING="--enable-logging=verbose"
+
+ econf $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ $(use_enable ssl encryption) \
+ $(use_enable static-libs static) \
+ --with-zlib=system \
+ ${LOGGING} \
+ --with-boost=${BOOST_INC} \
+ --with-boost-libdir=${BOOST_LIB} \
+ ${BOOST_LIBS}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die 'emake install failed'
+ use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
+ dodoc ChangeLog AUTHORS NEWS README || die 'dodoc failed'
+ if use doc ; then
+ dohtml docs/* || die "Could not install HTML documentation"
+ fi
+}