summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2012-04-19 13:04:12 -0400
committerJustin Riley <justin.t.riley@gmail.com>2012-04-19 13:04:12 -0400
commit413be3689f2df0bbc08cea9a6b5fbab0e331a1aa (patch)
tree7ab25268fff0bb270a686ead23f7dc53d2aee027 /dev-python
parentstarcluster: add updated 0.9999 ebuild (diff)
downloadjtriley-413be3689f2df0bbc08cea9a6b5fbab0e331a1aa.tar.gz
jtriley-413be3689f2df0bbc08cea9a6b5fbab0e331a1aa.tar.bz2
jtriley-413be3689f2df0bbc08cea9a6b5fbab0e331a1aa.zip
starcluster: update 9999 to use git-2 and develop branch
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/starcluster/starcluster-0.9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/starcluster/starcluster-0.9999.ebuild b/dev-python/starcluster/starcluster-0.9999.ebuild
index 2961197..07a3259 100644
--- a/dev-python/starcluster/starcluster-0.9999.ebuild
+++ b/dev-python/starcluster/starcluster-0.9999.ebuild
@@ -9,7 +9,7 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
DISTUTILS_SRC_TEST="nosetests"
-inherit distutils bash-completion git
+inherit distutils bash-completion git-2
MY_PN="StarCluster"
MY_P="${MY_PN}-${PV}"
@@ -18,6 +18,8 @@ DESCRIPTION="StarCluster is a utility for creating and managing general purpose
HOMEPAGE="http://web.mit.edu/star/cluster"
LICENSE="LGPL-2.1"
KEYWORDS="~amd64"
+EGIT_REPO_URI="http://github.com/jtriley/${MY_PN}.git"
+EGIT_BRANCH="develop"
SLOT="0"
IUSE="doc bash-completion"
@@ -40,8 +42,6 @@ PYTHON_MODNAME="${PN}"
DOCS="docs/sphinx/*"
-EGIT_REPO_URI="http://github.com/jtriley/${MY_PN}.git"
-
src_compile() {
distutils_src_compile
if use doc; then