summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/nmon/nmon-14i.ebuild')
-rw-r--r--sys-process/nmon/nmon-14i.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-process/nmon/nmon-14i.ebuild b/sys-process/nmon/nmon-14i.ebuild
new file mode 100644
index 0000000..cb376e7
--- /dev/null
+++ b/sys-process/nmon/nmon-14i.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/nmon/nmon-14i.ebuild,v 1.1 2014/03/19 20:58:31 polynomial-c Exp $
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Nigel's performance MONitor for CPU, memory, network, disks, etc..."
+HOMEPAGE="http://nmon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/lmon${PV}.c"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}"/lmon${PV}.c "${S}"/nmon.c || die
+}
+
+src_compile() {
+ # if ncurses is built with separate tinfo libs, then...
+ if has_version "sys-libs/ncurses[tinfo]" ; then
+ if has_version "sys-libs/ncurses[unicode]" ; then
+ CURSES_LIB="-lncursesw -ltinfow"
+ else
+ CURSES_LIB="-lncurses -ltinfo"
+ fi
+ else
+ if has_version "sys-libs/ncurses[unicode]" ; then
+ CURSES_LIB="-lncursesw"
+ else
+ CURSES_LIB="-lncurses"
+ fi
+ fi
+ append-cppflags -DJFS -DGETUSER -DLARGEMEM -DPOWER
+ emake CC="$(tc-getCC)" LDLIBS="${CURSES_LIB}" nmon
+}
+
+src_install() {
+ dobin nmon
+}