summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-11-08 15:10:21 +0100
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-11-08 15:31:09 +0100
commita9134bd145ca5cdfce4a99ad92079d0495df71f8 (patch)
treed936d8da35600307be9504ab6f146bb44b9bf7ce
parentupdate the rest (diff)
downloadkeruspe-a9134bd145ca5cdfce4a99ad92079d0495df71f8.tar.gz
keruspe-a9134bd145ca5cdfce4a99ad92079d0495df71f8.tar.bz2
keruspe-a9134bd145ca5cdfce4a99ad92079d0495df71f8.zip
make colord optional
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
-rw-r--r--gnome-base/gnome-control-center/Manifest2
-rw-r--r--gnome-base/gnome-control-center/files/gnome-control-center-3.2.1-optional-colord.patch66
-rw-r--r--gnome-base/gnome-control-center/gnome-control-center-9999-r1.ebuild108
-rw-r--r--gnome-base/gnome-settings-daemon/Manifest3
-rw-r--r--gnome-base/gnome-settings-daemon/files/0001-Make-colord-optional.patch124
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.2.1-optional-colord.patch95
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999-r1.ebuild119
7 files changed, 517 insertions, 0 deletions
diff --git a/gnome-base/gnome-control-center/Manifest b/gnome-base/gnome-control-center/Manifest
new file mode 100644
index 00000000..8137e416
--- /dev/null
+++ b/gnome-base/gnome-control-center/Manifest
@@ -0,0 +1,2 @@
+AUX gnome-control-center-3.2.1-optional-colord.patch 2005 RMD160 0a170f2ff2bd8886c3ecff18d22fc80a57497f2e SHA1 2047e863537832e3219564403a6207e8e8f7702b SHA256 852ca74531d54e65da41989f9c1c9f3883ecd7e31d0d4a17f6cca793c978284a
+EBUILD gnome-control-center-9999-r1.ebuild 2871 RMD160 4308e8c19f04384498706a6845e8d2112995a8d5 SHA1 ba3e81848786ce2bffa412cdfdd08c545bd66ec1 SHA256 12a702dcdc9850b4806d2a5b5ad6077fe2ecaddea99b23525dad4b3c05b6792d
diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.2.1-optional-colord.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.2.1-optional-colord.patch
new file mode 100644
index 00000000..edbbf314
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/gnome-control-center-3.2.1-optional-colord.patch
@@ -0,0 +1,66 @@
+From b56f9e04f8822db34b030bea86d39c1d444a3cbb Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Thu, 27 Oct 2011 23:55:23 -0400
+Subject: [PATCH] Make colord optional.
+
+---
+ configure.ac | 19 ++++++++++++++++++-
+ panels/Makefile.am | 5 ++++-
+ 2 files changed, 22 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index d552ac8..fd9062e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -106,7 +106,24 @@ PKG_CHECK_MODULES(NETWORK_PANEL, $COMMON_MODULES)
+ PKG_CHECK_MODULES(ONLINE_ACCOUNTS_PANEL, $COMMON_MODULES goa-1.0 goa-backend-1.0)
+ PKG_CHECK_MODULES(POWER_PANEL, $COMMON_MODULES upower-glib >= 0.9.1
+ gnome-settings-daemon >= $GSD_REQUIRED_VERSION)
+-PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES colord >= 0.1.8)
++build_color=false
++AC_ARG_ENABLE(color,
++ AC_HELP_STRING([--disable-color],
++ [disable color management panel]),
++ [case "${enableval}" in
++ yes) WANT_COLOR=yes ;;
++ no) WANT_COLOR=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-color) ;;
++ esac],
++ [WANT_COLOR=yes]) dnl Default value
++
++if test x$WANT_COLOR = xyes; then
++ PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES colord >= 0.1.8)
++ build_color=true
++fi
++AM_CONDITIONAL(BUILD_COLOR, test "x$build_color" = "xtrue")
++AC_SUBST(COLOR_PANEL_CFLAGS)
++AC_SUBST(COLOR_PANEL_LIBS)
+ PKG_CHECK_MODULES(PRINTERS_PANEL, $COMMON_MODULES dbus-glib-1
+ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION)
+ PKG_CHECK_MODULES(REGION_PANEL, $COMMON_MODULES libgnomekbd >= 2.91.91
+diff --git a/panels/Makefile.am b/panels/Makefile.am
+index 566a2f8..a375e2f 100644
+--- a/panels/Makefile.am
++++ b/panels/Makefile.am
+@@ -3,7 +3,6 @@ SUBDIRS= \
+ background \
+ screen \
+ power \
+- color \
+ display \
+ media \
+ mouse \
+@@ -17,6 +16,10 @@ SUBDIRS= \
+ datetime \
+ wacom
+
++if BUILD_COLOR
++SUBDIRS += color
++endif
++
+ if BUILD_PRINTERS
+ SUBDIRS += printers
+ endif
+--
+1.7.7.1
+
diff --git a/gnome-base/gnome-control-center/gnome-control-center-9999-r1.ebuild b/gnome-base/gnome-control-center/gnome-control-center-9999-r1.ebuild
new file mode 100644
index 00000000..32030c22
--- /dev/null
+++ b/gnome-base/gnome-control-center/gnome-control-center-9999-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes" # gmodule is used, which uses dlopen
+
+inherit gnome2-live
+
+DESCRIPTION="GNOME Desktop Configuration Tool"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+IUSE="+cheese +colord +cups +networkmanager +socialweb"
+KEYWORDS=""
+
+# XXX: gnome-desktop-2.91.5 is needed for upstream commit c67f7efb
+# XXX: NetworkManager-0.9 support is automagic, make hard-dep once it's released
+#
+# gnome-session-2.91.6-r1 is needed so that 10-user-dirs-update is run at login
+# Latest gsettings-desktop-schemas is neededfor commit 73f9bffb
+# gnome-settings-daemon-3.1.4 is needed for power panel (commit 4f08a325)
+COMMON_DEPEND="
+ >=dev-libs/glib-2.29.14:2
+ >=x11-libs/gdk-pixbuf-2.23.0:2
+ >=x11-libs/gtk+-3.1.19:3
+ >=gnome-base/gsettings-desktop-schemas-3.0.2
+ >=gnome-base/gconf-2.0:2
+ >=dev-libs/dbus-glib-0.73
+ >=gnome-base/gnome-desktop-3.1.0:3
+ >=gnome-base/gnome-settings-daemon-3.1.4[colord(+)?]
+ >=gnome-base/libgnomekbd-2.91.91
+
+ app-text/iso-codes
+ dev-libs/libxml2:2
+ gnome-base/gnome-menus:3
+ gnome-base/libgtop:2
+ media-libs/fontconfig
+ net-libs/gnome-online-accounts
+
+ >=media-libs/libcanberra-0.13[gtk3]
+ >=media-sound/pulseaudio-0.9.16[glib]
+ >=sys-auth/polkit-0.97
+ >=sys-power/upower-0.9.1
+ >=x11-libs/libnotify-0.7.3
+
+ x11-apps/xmodmap
+ x11-libs/libX11
+ x11-libs/libXxf86misc
+ >=x11-libs/libxklavier-5.1
+ >=x11-libs/libXi-1.2
+
+ cheese? (
+ media-libs/gstreamer:0.10
+ >=media-video/cheese-2.91.91.1 )
+ colord? ( >=x11-misc/colord-0.1.8 )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ networkmanager? (
+ >=gnome-extra/nm-applet-0.9.1.90
+ >=net-misc/networkmanager-0.8.997 )
+ socialweb? ( net-libs/libsocialweb )"
+# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x
+RDEPEND="${COMMON_DEPEND}
+ app-admin/apg
+ sys-apps/accountsservice
+ cups? ( net-print/cups-pk-helper )
+
+ !<gnome-extra/gnome-color-manager-3.1.2
+ !gnome-extra/gnome-media[pulseaudio]
+ !<gnome-extra/gnome-media-2.32.0-r300
+ !<gnome-base/gdm-2.91.94"
+# PDEPEND to avoid circular dependency
+PDEPEND=">=gnome-base/gnome-session-2.91.6-r1"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+ x11-proto/xf86miscproto
+ x11-proto/kbproto
+
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40.1
+ >=dev-util/pkgconfig-0.19
+
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.10.1
+
+ cups? ( sys-apps/sed )"
+# Needed for autoreconf
+# gnome-base/gnome-common
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-update-mimedb
+ --disable-static
+ $(use_with cheese)
+ $(use_enable colord color)
+ $(use_enable cups)
+ $(use_with socialweb libsocialweb)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+src_prepare() {
+ # Make colord plugin optional; requires eautoreconf
+ epatch "${FILESDIR}/${PN}-3.2.1-optional-colord.patch"
+
+ gnome2_src_prepare
+}
diff --git a/gnome-base/gnome-settings-daemon/Manifest b/gnome-base/gnome-settings-daemon/Manifest
new file mode 100644
index 00000000..0c648a3a
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/Manifest
@@ -0,0 +1,3 @@
+AUX 0001-Make-colord-optional.patch 4478 RMD160 a8bfd5541018cc21b2818d4813c454a53e0c5394 SHA1 3c620b4ff439bdf2603309e778ff3b0a6c1ba8be SHA256 6cd403a470e954b7312bb56a1175a80c45d440afc40719a12cc5485531afc89f
+AUX gnome-settings-daemon-3.2.1-optional-colord.patch 2934 RMD160 cefc964b1c6449807043977b81ac4f593f37b7e3 SHA1 e1fa059374a429fe532af88f3a490d0ad5a2153a SHA256 2eb0e6cffd2fc579ece5cbe36950a28e9831d63764d8b5fae89df711ead4bf52
+EBUILD gnome-settings-daemon-9999-r1.ebuild 3465 RMD160 fd0c3b01ef0755b4149e7c90dcc5757b8f096ec5 SHA1 ae63c49cf876eac5380ff3056a7b69ee5bdb043c SHA256 1a361246f315ca2dade57450ae1ee88d61be37a882807aaba8b6e3c80e76813e
diff --git a/gnome-base/gnome-settings-daemon/files/0001-Make-colord-optional.patch b/gnome-base/gnome-settings-daemon/files/0001-Make-colord-optional.patch
new file mode 100644
index 00000000..e57d21f6
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/0001-Make-colord-optional.patch
@@ -0,0 +1,124 @@
+From a70d512823b818f46ddb40213c2658100d4cadc0 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Thu, 27 Oct 2011 23:30:41 -0400
+Subject: [PATCH] Make colord optional
+
+Conflicts:
+
+ configure.ac
+ plugins/Makefile.am
+---
+ configure.ac | 38 ++++++++++++++++++++++++++++++++------
+ data/Makefile.am | 7 ++++++-
+ plugins/Makefile.am | 7 ++++++-
+ 3 files changed, 44 insertions(+), 8 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 08b1a2f..4f6f75f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -105,6 +105,38 @@ dnl ---------------------------------------------------------------------------
+ PKG_CHECK_MODULES(GNOME_DESKTOP, gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION)
+
+ dnl ---------------------------------------------------------------------------
++dnl - Check for colord
++dnl ---------------------------------------------------------------------------
++build_color=false
++AC_ARG_ENABLE(color,
++ AC_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [case "${enableval}" in
++ yes) WANT_COLOR=yes ;;
++ no) WANT_COLOR=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-color) ;;
++ esac],
++ [WANT_COLOR=yes]) dnl Default value
++
++if test x$WANT_COLOR = xyes; then
++ PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++ build_color=true
++fi
++AM_CONDITIONAL(BUILD_COLOR, test "x$build_color" = "xtrue")
++
++AC_SUBST(COLORD_CFLAGS)
++AC_SUBST(COLORD_LIBS)
++
++dnl ---------------------------------------------------------------------------
++dnl - Check for libcanberra
++dnl ---------------------------------------------------------------------------
++PKG_CHECK_MODULES(LIBCANBERRA, libcanberra-gtk3,
++ [have_libcanberra=true
++ AC_DEFINE(HAVE_LIBCANBERRA, 1, [Define if libcanberra should be used])],
++ [have_libcanberra=false])
++AM_CONDITIONAL(HAVE_LIBCANBERRA, test "x$have_libcanberra" = "xtrue")
++
++dnl ---------------------------------------------------------------------------
+ dnl - Check for LCMS2
+ dnl ---------------------------------------------------------------------------
+ PKG_CHECK_MODULES(LCMS, lcms2 >= 2.2, have_new_lcms=yes, have_new_lcms=no)
+@@ -219,12 +251,6 @@ dnl ---------------------------------------------------------------------------
+
+ PKG_CHECK_MODULES(MEDIA_KEYS, [gio-unix-2.0 libpulse >= $PA_REQUIRED_VERSION $GUDEV_PKG libpulse-mainloop-glib >= $PA_REQUIRED_VERSION libcanberra gconf-2.0 >= $GCONF_REQUIRED_VERSION])
+
+-dnl ---------------------------------------------------------------------------
+-dnl - color
+-dnl ---------------------------------------------------------------------------
+-
+-PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
+-
+ dnl ==============================================
+ dnl PackageKit section
+ dnl ==============================================
+diff --git a/data/Makefile.am b/data/Makefile.am
+index 43ba27c..1f3bbef 100644
+--- a/data/Makefile.am
++++ b/data/Makefile.am
+@@ -11,7 +11,6 @@ gsettings_SCHEMAS = \
+ org.gnome.settings-daemon.plugins.gschema.xml \
+ org.gnome.settings-daemon.plugins.keyboard.gschema.xml \
+ org.gnome.settings-daemon.plugins.power.gschema.xml \
+- org.gnome.settings-daemon.plugins.color.gschema.xml \
+ org.gnome.settings-daemon.plugins.media-keys.gschema.xml \
+ org.gnome.settings-daemon.plugins.xsettings.gschema.xml \
+ org.gnome.settings-daemon.plugins.housekeeping.gschema.xml \
+@@ -21,6 +20,12 @@ gsettings_SCHEMAS = \
+
+ all_schemas = $(gsettings_SCHEMAS)
+
++if BUILD_COLOR
++gsettings_SCHEMAS += org.gnome.settings-daemon.plugins.color.gschema.xml
++else
++all_schemas += org.gnome.settings-daemon.plugins.color.gschema.xml
++endif
++
+ if HAVE_PACKAGEKIT
+ gsettings_SCHEMAS += org.gnome.settings-daemon.plugins.updates.gschema.xml
+ else
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index 83d223a..ad88aa9 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -6,7 +6,6 @@ enabled_plugins = \
+ automount \
+ background \
+ clipboard \
+- color \
+ cursor \
+ datetime \
+ dummy \
+@@ -23,6 +22,12 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if BUILD_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if HAVE_PACKAGEKIT
+ enabled_plugins += updates
+ else
+--
+1.7.8.rc0.dirty
+
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.2.1-optional-colord.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.2.1-optional-colord.patch
new file mode 100644
index 00000000..98afbec6
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.2.1-optional-colord.patch
@@ -0,0 +1,95 @@
+From e1e0584cec966dc58a51efaf534f129b4830399f Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Thu, 27 Oct 2011 23:30:41 -0400
+Subject: [PATCH] Make colord optional
+
+---
+ configure.ac | 20 +++++++++++++++++++-
+ data/Makefile.am | 7 ++++++-
+ plugins/Makefile.am | 7 ++++++-
+ 3 files changed, 31 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fe74674..f1a8547 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -107,7 +107,25 @@ PKG_CHECK_MODULES(GNOME_DESKTOP, gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VE
+ dnl ---------------------------------------------------------------------------
+ dnl - Check for colord
+ dnl ---------------------------------------------------------------------------
+-PKG_CHECK_MODULES(COLORD, colord >= 0.1.12)
++build_color=false
++AC_ARG_ENABLE(color,
++ AC_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [case "${enableval}" in
++ yes) WANT_COLOR=yes ;;
++ no) WANT_COLOR=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-color) ;;
++ esac],
++ [WANT_COLOR=yes]) dnl Default value
++
++if test x$WANT_COLOR = xyes; then
++ PKG_CHECK_MODULES(COLORD, colord >= 0.1.12)
++ build_color=true
++fi
++AM_CONDITIONAL(BUILD_COLOR, test "x$build_color" = "xtrue")
++
++AC_SUBST(COLORD_CFLAGS)
++AC_SUBST(COLORD_LIBS)
+
+ dnl ---------------------------------------------------------------------------
+ dnl - Check for libcanberra
+diff --git a/data/Makefile.am b/data/Makefile.am
+index 43ba27c..1f3bbef 100644
+--- a/data/Makefile.am
++++ b/data/Makefile.am
+@@ -11,7 +11,6 @@ gsettings_SCHEMAS = \
+ org.gnome.settings-daemon.plugins.gschema.xml \
+ org.gnome.settings-daemon.plugins.keyboard.gschema.xml \
+ org.gnome.settings-daemon.plugins.power.gschema.xml \
+- org.gnome.settings-daemon.plugins.color.gschema.xml \
+ org.gnome.settings-daemon.plugins.media-keys.gschema.xml \
+ org.gnome.settings-daemon.plugins.xsettings.gschema.xml \
+ org.gnome.settings-daemon.plugins.housekeeping.gschema.xml \
+@@ -21,6 +20,12 @@ gsettings_SCHEMAS = \
+
+ all_schemas = $(gsettings_SCHEMAS)
+
++if BUILD_COLOR
++gsettings_SCHEMAS += org.gnome.settings-daemon.plugins.color.gschema.xml
++else
++all_schemas += org.gnome.settings-daemon.plugins.color.gschema.xml
++endif
++
+ if HAVE_PACKAGEKIT
+ gsettings_SCHEMAS += org.gnome.settings-daemon.plugins.updates.gschema.xml
+ else
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index 5e26811..d2404ab 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -6,7 +6,6 @@ enabled_plugins = \
+ automount \
+ background \
+ clipboard \
+- color \
+ cursor \
+ datetime \
+ dummy \
+@@ -24,6 +23,12 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if BUILD_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if BUILD_GCONF_BRIDGE
+ enabled_plugins += gconf
+ else
+--
+1.7.7.1
+
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999-r1.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999-r1.ebuild
new file mode 100644
index 00000000..f543a14c
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2-live virtualx
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+colord +cups debug packagekit policykit short-touchpad-timeout smartcard +udev"
+
+# Latest gsettings-desktop-schemas is needed due to commit e8d1de92
+# Latest gnome-desktop needed to fix the DPMS timeout bug #385063
+# colord-0.1.13 needed to avoid polkit errors in CreateProfile and CreateDevice
+# upower-0.9.11 needed for UpSleepKind
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.29.14:2
+ >=x11-libs/gtk+-3.3.3:3
+ >=gnome-base/gconf-2.6.1:2
+ >=gnome-base/libgnomekbd-2.91.1
+ >=gnome-base/gnome-desktop-3.2.0-r1:3
+ >=gnome-base/gsettings-desktop-schemas-0.1.7.1
+ media-fonts/cantarell
+ media-libs/fontconfig
+ >=media-libs/lcms-2.2:2
+ media-libs/libcanberra[gtk3]
+ >=media-sound/pulseaudio-0.9.16
+ >=sys-power/upower-0.9.11
+ >=x11-libs/libnotify-0.7.3
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXxf86misc
+ >=x11-libs/libxklavier-5.0
+ >=media-sound/pulseaudio-0.9.16
+
+ colord? ( >=x11-misc/colord-0.1.13 )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ packagekit? (
+ || ( sys-fs/udev[gudev]
+ sys-fs/udev[extras] )
+ >=app-admin/packagekit-base-0.6.12 )
+ policykit? (
+ >=sys-auth/polkit-0.97
+ >=sys-apps/dbus-1.1.2[X] )
+ smartcard? ( >=dev-libs/nss-3.11.2 )
+ udev? ( || ( sys-fs/udev[gudev]
+ sys-fs/udev[extras] ) )"
+# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
+# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
+# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ >=x11-themes/gnome-themes-standard-2.91
+ >=x11-themes/gnome-icon-theme-2.91
+ >=x11-themes/gnome-icon-theme-symbolic-2.91
+ !<gnome-base/gnome-control-center-2.22
+ !<gnome-extra/gnome-color-manager-3.1.1
+ !<gnome-extra/gnome-power-manager-3.1.3"
+# xproto-7.0.15 needed for power plugin
+DEPEND="${COMMON_DEPEND}
+ cups? ( sys-apps/sed )
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.19
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/xf86miscproto
+ >=x11-proto/xproto-7.0.15"
+
+pkg_setup() {
+ # README is empty
+ DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ --enable-gconf-bridge
+ --with-pnpids=${EPREFIX}/usr/share/libgnome-desktop-3.0/pnp.ids
+ $(use_enable colord color)
+ $(use_enable cups)
+ $(use_enable debug)
+ $(use_enable debug more-warnings)
+ $(use_enable packagekit)
+ $(use_enable policykit polkit)
+ $(use_enable smartcard smartcard-support)
+ $(use_enable udev gudev)"
+}
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=621836
+ # Apparently this change severely affects touchpad usability for some
+ # people, so revert it if USE=short-touchpad-timeout.
+ # Revisit if/when upstream adds a setting for customizing the timeout.
+ use short-touchpad-timeout &&
+ epatch "${FILESDIR}/${PN}-3.0.2-short-touchpad-timeout.patch"
+
+ # Make colord optional; requires eautoreconf
+ epatch "${FILESDIR}/0001-Make-colord-optional.patch"
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51gsettings-dconf
+ doenvd 51gsettings-dconf || die "doenvd failed"
+}