summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2012-04-12 17:37:03 +0200
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2012-04-12 17:37:03 +0200
commit99c7a989e91ab1f516ef35e489bc8bbf0ea682ba (patch)
tree86c5e4748adbe14bcf0938f8582dcd296c122d5f /dev-lang/vala/vala-9999.ebuild
parentupdate gpaste (diff)
downloadkeruspe-99c7a989e91ab1f516ef35e489bc8bbf0ea682ba.tar.gz
keruspe-99c7a989e91ab1f516ef35e489bc8bbf0ea682ba.tar.bz2
keruspe-99c7a989e91ab1f516ef35e489bc8bbf0ea682ba.zip
I do not maintain this stuff anymore
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Diffstat (limited to 'dev-lang/vala/vala-9999.ebuild')
-rw-r--r--dev-lang/vala/vala-9999.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-lang/vala/vala-9999.ebuild b/dev-lang/vala/vala-9999.ebuild
deleted file mode 100644
index 84c8ad0c..00000000
--- a/dev-lang/vala/vala-9999.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit alternatives gnome2-live
-
-DESCRIPTION="Vala - Compiler for the GObject type system"
-HOMEPAGE="http://live.gnome.org/Vala"
-
-LICENSE="LGPL-2.1"
-SLOT="0.18"
-OLD_SLOT="0.16"
-KEYWORDS=""
-IUSE="bootstrap test +vapigen"
-
-RDEPEND=">=dev-libs/glib-2.16:2"
-DEPEND="${RDEPEND}
- !bootstrap? ( dev-lang/vala:${SLOT} )
- bootstrap? ( dev-lang/vala:${OLD_SLOT} )
- sys-devel/flex
- || ( sys-devel/bison dev-util/byacc dev-util/yacc )
- dev-util/pkgconfig
- dev-libs/libxslt
- test? (
- dev-libs/dbus-glib
- >=dev-libs/glib-2.26:2 )"
-
-pkg_setup() {
- local WANTED_SLOT
- if use bootstrap; then
- WANTED_SLOT=${OLD_SLOT}
- else
- WANTED_SLOT=${SLOT}
- fi
- G2CONF="${G2CONF}
- VALAC=$(type -P valac-${WANTED_SLOT})
- --disable-unversioned
- $(use_enable vapigen)"
- DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
-}
-
-src_install() {
- gnome2_src_install
-
- insinto /usr/share/aclocal
- newins vala.m4 vala-${SLOT/./-}.m4
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- alternatives_auto_makesym /usr/share/aclocal/vala.m4 "vala-0-[0-9][0-9].m4"
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- alternatives_auto_makesym /usr/share/aclocal/vala.m4 "vala-0-[0-9][0-9].m4"
-}