summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libpeas/libpeas-9999-r1.ebuild')
-rw-r--r--dev-libs/libpeas/libpeas-9999-r1.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-libs/libpeas/libpeas-9999-r1.ebuild b/dev-libs/libpeas/libpeas-9999-r1.ebuild
deleted file mode 100644
index b0f9f6ca..00000000
--- a/dev-libs/libpeas/libpeas-9999-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_DEPEND="python? 2:2.5"
-
-inherit gnome2-live python virtualx
-
-DESCRIPTION="A GObject plugins library"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="doc gjs +gtk glade +python seed vala"
-KEYWORDS=""
-
-RDEPEND=">=dev-libs/glib-2.23.6:2
- >=dev-libs/gobject-introspection-0.10.1
- gjs? ( >=dev-libs/gjs-1.29.16 )
- glade? ( >=dev-util/glade-3.9.1:3.10 )
- gtk? ( >=x11-libs/gtk+-2.91.1:3[introspection] )
- python? ( >=dev-python/pygobject-3.0.0:3 )
- seed? ( >=dev-libs/seed-2.91.91 )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40
- >=sys-devel/gettext-0.17
- doc? ( >=dev-util/gtk-doc-1.11 )
- vala? ( dev-lang/vala:0.14 )"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- $(use_enable gjs)
- $(use_enable glade glade-catalog)
- $(use_enable gtk)
- $(use_enable python)
- $(use_enable seed)
- $(use_enable vala)
- VALAC=$(type -P valac-0.14)
- --disable-deprecation
- --disable-static"
- # Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
- # What do we do about gdb, valgrind, gcov, etc?
-
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_test() {
- # FIXME: Tests fail because of some bug involving Xvfb and Gtk.IconTheme
- # DO NOT REPORT UPSTREAM, this is not a libpeas bug.
- # To reproduce:
- # >>> from gi.repository import Gtk
- # >>> Gtk.IconTheme.get_default().has_icon("gtk-about")
- # This should return True, it returns False for Xvfb
- Xemake check
-}