summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2010-11-11 15:56:45 +0100
committerHenry Gebhardt <hsggebhardt@googlemail.com>2010-11-11 20:56:02 +0100
commit22be250d13e61c8dbc77c91b89bb22687a02583f (patch)
tree53eb89a050e2340c0e80c8c844a8f29627b2288a
parentsci-astronomy/ftools-6.10: Fix revdep-control file generation (diff)
downloadkork-22be250d13e61c8dbc77c91b89bb22687a02583f.tar.gz
kork-22be250d13e61c8dbc77c91b89bb22687a02583f.tar.bz2
kork-22be250d13e61c8dbc77c91b89bb22687a02583f.zip
sci-astronomy/fpipe-9999: Add 'doc' use flag, remove IPC::XPA dependency
-rw-r--r--sci-astronomy/fpipe/Manifest2
-rw-r--r--sci-astronomy/fpipe/fpipe-9999.ebuild21
2 files changed, 13 insertions, 10 deletions
diff --git a/sci-astronomy/fpipe/Manifest b/sci-astronomy/fpipe/Manifest
index b95fe7c..222ba6d 100644
--- a/sci-astronomy/fpipe/Manifest
+++ b/sci-astronomy/fpipe/Manifest
@@ -1 +1 @@
-EBUILD fpipe-9999.ebuild 1849 RMD160 73de85030982ea4f14794533ffc7c7d27509f692 SHA1 5d7061eb1aadd1a5eecab7830fc69b4bb9a21a6c SHA256 0c3a00d8a785558448374630e3e84d455296da0201169b53fbdd3186e3f79eba
+EBUILD fpipe-9999.ebuild 1985 RMD160 ea330776ee24415aaa3421539d542ce5c8010ef0 SHA1 6d38aa13f5c0dfca1d7d3fbbb027c87ce79d143e SHA256 1291467478da691f1ee69049bd41ac696cf7a45ee94f31bd7cef66bbc606ed1b
diff --git a/sci-astronomy/fpipe/fpipe-9999.ebuild b/sci-astronomy/fpipe/fpipe-9999.ebuild
index d5fbf0d..b8113f3 100644
--- a/sci-astronomy/fpipe/fpipe-9999.ebuild
+++ b/sci-astronomy/fpipe/fpipe-9999.ebuild
@@ -12,8 +12,10 @@ EGIT_REPO_URI="git://git.tokkee.org/fpipe.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="debug"
+IUSE="debug +doc"
+# sci-astronomy/ftools is only needed because of the ape library, cfitsio and
+# xpa can be installed separately, an ebuild even exists for those.
DEPEND=">=x11-libs/gtk+-2.14
media-gfx/gtkimageview
dev-lang/perl
@@ -21,9 +23,8 @@ DEPEND=">=x11-libs/gtk+-2.14
dev-perl/XML-Simple
dev-perl/XML-SAX-Expat
virtual/perl-Time-HiRes
- perl-gcpan/IPC-XPA
virtual/libusb:1
- virtual/latex-base
+ doc? ( virtual/latex-base )
>=sci-astronomy/ftools-6.10"
pkg_setup() {
@@ -45,8 +46,6 @@ src_configure() {
cd software
econf $(use_enable debug debug 1) \
- --disable-fpcmsimulator \
- --enable-fpimage \
--enable-fpixoacm2fits \
--enable-fpixosvm2fits \
--enable-fptemplate \
@@ -57,8 +56,10 @@ src_compile() {
cd software
emake || die "emake failed"
- cd "${S}"/documents
- emake || die "emake failed for documents"
+ if use doc; then
+ cd "${S}"/documents
+ emake || die "emake failed for documents"
+ fi
}
src_install() {
@@ -69,8 +70,10 @@ src_install() {
insinto /usr/share/"${PN}"/pipelinedef
doins *
- cd "${S}"/documents
- dodoc *.pdf *.odf
+ if use doc; then
+ cd "${S}"/documents
+ dodoc *.pdf *.odf
+ fi
}
pkg_postinst() {