summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/redo/redo-0.11-r1.ebuild')
-rw-r--r--sys-devel/redo/redo-0.11-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-devel/redo/redo-0.11-r1.ebuild b/sys-devel/redo/redo-0.11-r1.ebuild
index b143c3f..b51b3dd 100644
--- a/sys-devel/redo/redo-0.11-r1.ebuild
+++ b/sys-devel/redo/redo-0.11-r1.ebuild
@@ -2,8 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=6
inherit eutils bash-completion-r1
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
DESCRIPTION="Smaller, easier, more powerful, and more reliable than make. An implementation of djb's redo."
HOMEPAGE="http://github.com/apenwarr/redo"
@@ -48,6 +50,8 @@ src_compile() {
src_install() {
emake install DESTDIR="${D}" || die "emake install failed"
+ python_doscript "${D}/usr/bin"/*
+
dobashcomp contrib/bash_completion.d/redo
dodoc "${D}/usr/share/doc/${PN}"/* && rm -r "${D}/usr/share/doc/${PN}/"