aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2017-12-17 13:16:36 +0000
committerPaul Healy <lmiphay@gmail.com>2017-12-17 13:16:36 +0000
commit67575915e110aa8f0d1feec0b1dc9c144d8bda79 (patch)
tree164470d0323b25d62c362d5b78ed79fae4385999 /app-crypt
parentadd certbot; old dir for logrotate (diff)
downloadlmiphay-67575915e110aa8f0d1feec0b1dc9c144d8bda79.tar.gz
lmiphay-67575915e110aa8f0d1feec0b1dc9c144d8bda79.tar.bz2
lmiphay-67575915e110aa8f0d1feec0b1dc9c144d8bda79.zip
add ebuild for ssl-cert-check
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/ssl-cert-check/Manifest1
-rw-r--r--app-crypt/ssl-cert-check/ssl-cert-check-20171114.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/ssl-cert-check/Manifest b/app-crypt/ssl-cert-check/Manifest
new file mode 100644
index 0000000..d2a0142
--- /dev/null
+++ b/app-crypt/ssl-cert-check/Manifest
@@ -0,0 +1 @@
+EBUILD ssl-cert-check-20171114.ebuild 565 SHA256 fda100c25dad806256c4d24b361ec76527d0e17dd0a4f247d7d0847726c1af46 SHA512 237f72885509cd8640987a4cacc6f74ab8528381d318badfc62ec98e6962d36cceed2dd00c00250c1f761344b46878733fe2d559cc978dcf1268439d97863471 WHIRLPOOL a5008e3ca7d574658dbc35fb219c0cdc898eb32a9e6ae4cc7e6cb1f629964420d523b67ef4bd7bab8a01dd622d7d86a515e48607e6d06723c6e535de3d30d214
diff --git a/app-crypt/ssl-cert-check/ssl-cert-check-20171114.ebuild b/app-crypt/ssl-cert-check/ssl-cert-check-20171114.ebuild
new file mode 100644
index 0000000..2a0c6dc
--- /dev/null
+++ b/app-crypt/ssl-cert-check/ssl-cert-check-20171114.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit git-r3
+
+DESCRIPTION="Send notifications when SSL certificates are about to expire"
+HOMEPAGE="https://github.com/Matty9191/ssl-cert-check"
+EGIT_REPO_URI="https://github.com/Matty9191/ssl-cert-check.git"
+EGIT_COMMIT="7e554814bc8d4048f75555f3a331df4e0506998c"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-shells/bash
+ dev-libs/openssl
+"
+
+src_install() {
+ dobin ssl-cert-check
+ dodoc README.md
+}