aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2015-08-09 11:17:23 +0100
committerPaul Healy <lmiphay@gmail.com>2015-08-09 11:17:23 +0100
commit7cf94b8f125723b6e28d469e258d4d0c91d835bc (patch)
tree50d424da7ff66f27a27a20f9a3976911a3f4d3be /dev-util
parentpick the exact file versions from cgit (diff)
downloadlmiphay-7cf94b8f125723b6e28d469e258d4d0c91d835bc.tar.gz
lmiphay-7cf94b8f125723b6e28d469e258d4d0c91d835bc.tar.bz2
lmiphay-7cf94b8f125723b6e28d469e258d4d0c91d835bc.zip
pseudo live ebuild - caches first time - TBF
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gstack/gstack-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/gstack/gstack-9999.ebuild b/dev-util/gstack/gstack-9999.ebuild
new file mode 100644
index 0000000..eede736
--- /dev/null
+++ b/dev-util/gstack/gstack-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Display stack trace of a running process."
+HOMEPAGE="https://admin.fedoraproject.org/pkgdb/package/gdb/"
+
+# the patch file has been updated a number of times since 20050411 without
+# changing the file name.
+patchfile="gdb-6.3-${PN}-20050411.patch"
+manpage="gdb-${PN}.man"
+
+SRC_URI="
+ http://pkgs.fedoraproject.org/cgit/gdb.git/plain/${patchfile} -> ${patchfile}_${PV}
+ http://pkgs.fedoraproject.org/cgit/gdb.git/plain/${manpage} -> ${manpage}_${PV}
+"
+RESTRICT="mirror"
+
+SLOT="0"
+LICENSE="GPL-2 GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-util/patchutils
+"
+RDEPEND="
+ sys-devel/gdb
+"
+
+src_unpack() {
+ mkdir -p ${S}
+}
+
+src_prepare() {
+ filterdiff -i '*/gstack.sh' ${DISTDIR}/${patchfile}_${PV} | patch -p2
+ epatch_user
+}
+
+src_install() {
+ newbin gstack.sh gstack
+ newman ${DISTDIR}/${manpage}_${PV} gstack.1
+}