aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-10-23 21:59:16 +0100
committerPaul Healy <lmiphay@gmail.com>2018-10-23 21:59:16 +0100
commit330551471a44f8cb3b2c23932adf848c01a934c3 (patch)
tree15221c1d82740f17d963a3c8401c19731b56d831 /media-sound
parentadd bindfs dep; add new driver (diff)
downloadlmiphay-330551471a44f8cb3b2c23932adf848c01a934c3.tar.gz
lmiphay-330551471a44f8cb3b2c23932adf848c01a934c3.tar.bz2
lmiphay-330551471a44f8cb3b2c23932adf848c01a934c3.zip
add ebuild for v0.1
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lms-gd/Manifest2
-rw-r--r--media-sound/lms-gd/lms-gd-0.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/lms-gd/Manifest b/media-sound/lms-gd/Manifest
index 5608f0b..f0fb45f 100644
--- a/media-sound/lms-gd/Manifest
+++ b/media-sound/lms-gd/Manifest
@@ -1 +1,3 @@
+DIST lms-gd-0.1.tar.gz 9916 BLAKE2B 95b15d85438a8d067d1d6dc2b94c66ea4152234b93d33e9d2573d4d3d80bd15a6e35eb2c57457fe0d41d0c18ae10cd48dbbd8e5820a3c6c44d30422d43c5da96 SHA512 6a93bf24bb346e49ab6915f50de49ebc6302627a6e8d9eccc2ae7b9f81306e05307e3168a06002ef029709dcae9d6a438f0a205c12a63516658544214ebda384
+EBUILD lms-gd-0.1.ebuild 977 BLAKE2B 9cf37b6c9fbb93a92d5ff7f84abd116aee4139d162259831159ea22c436d726f8011f80387a90c082c09a33b57fbf9e481985c125d1bb28729bc73fdd88216bf SHA512 9fef78f9ceaeab51c5a27ccc07b73fa7c5a428c99e3d57a95dd704a76ff56b467d5773dd7af2c6648e83c4fde95836ae825618ab5aaadddeb2e61441c574697c
EBUILD lms-gd-9999.ebuild 974 BLAKE2B 9d53776bcf1c209d902f1db3e3645c59f89fe2fafefd83ae5d6ac6187253d542f6c9bf1d94adc5facfe378be4fba8ca6999c4acb22d56e02cfe65c27006470f7 SHA512 51792e8cadaf753c0d1f1c85598b05a04675ecd66fe39802fe7383562443580872ad9ed4d3873ae31a3eccd018f4b4b6f316d451b8071b70839cd22d893decc8
diff --git a/media-sound/lms-gd/lms-gd-0.1.ebuild b/media-sound/lms-gd/lms-gd-0.1.ebuild
new file mode 100644
index 0000000..eeb2e23
--- /dev/null
+++ b/media-sound/lms-gd/lms-gd-0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="logitechmediaserver in a gentoo docker"
+HOMEPAGE="https://github.com/lmiphay/lms-gd"
+SRC_URI="https://github.com/lmiphay/lms-gd/archive/v0.1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-emulation/docker
+ dev-vcs/git
+"
+
+DISABLE_AUTOFORMATTING=1
+FORCE_PRINT_ELOG=1
+DOC_CONTENTS="
+ This is an experimental attempt at running logitechmediaserver in a gentoo docker
+
+ Please report issues at the bug tracker: https://github.com/lmiphay/lms-gd/issues
+"
+
+DOCS=( "README.md" )
+
+src_install() {
+ dobin "${PN}"
+
+ insinto /usr/share/lms-gd
+ doins Dockerfile lms.keywords lms.use make.conf.lms-gd squeezebox.conf
+
+ newconfd "${PN}.conf.d" "${PN}"
+ newinitd "${PN}.init.d" "${PN}"
+
+ readme.gentoo_create_doc
+
+ default
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}