summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukas Elsner <open@mindrunner.de>2014-02-12 20:26:29 +0100
committerLukas Elsner <open@mindrunner.de>2014-02-12 20:26:29 +0100
commitf99527316f29ffea52a5a24b457290f2c4260768 (patch)
treead24564a6d97469a75a84dd6443340d7e4ec1609
parentsmall fix (diff)
downloadluman-f99527316f29ffea52a5a24b457290f2c4260768.tar.gz
luman-f99527316f29ffea52a5a24b457290f2c4260768.tar.bz2
luman-f99527316f29ffea52a5a24b457290f2c4260768.zip
added pycharm
-rw-r--r--dev-util/pycharm-community/Manifest2
-rw-r--r--dev-util/pycharm-community/pycharm-community-3.1.0.133.804.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
new file mode 100644
index 0000000..c82eeca
--- /dev/null
+++ b/dev-util/pycharm-community/Manifest
@@ -0,0 +1,2 @@
+DIST pycharm-community-3.1.tar.gz 107638674 SHA256 5f27fb2b5834d7560b59f96a7dd16959f0086b8367edeb73d721f36b8f007af0 SHA512 00b07b0c4a9a289cb55162a7516e181a0f8570f3173bb0544ed5a9a8146539401ffc94a8d79386369077a74a03d360278edb950a15d8c541d0613bd6b92e9c27 WHIRLPOOL ee58c55eb0bf57aafb4788a746f4fce57d1287a3b7122f99e152f0a62e29fab9af17a0522c5706e0cd65eba05cd8168ac027ea3dc5326c27100d9b2861a420f8
+EBUILD pycharm-community-3.1.0.133.804.ebuild 2305 SHA256 870719b109190b236cc36c4144c726b944c1d88302ad3d0ddc9346d97e5bd9b2 SHA512 51f4bf7236c4ebb02dd71309c38859fa4c867adaa65e3eb07d53dcfedf5fc81c389a959fa382d5ad6ef31467a73bbda46ecac0be7948a75a7808928a62a733d0 WHIRLPOOL 2cae13e5a6b151177f1943a05145a668fc1cb637cee0d8b6a8a8365d41c2fb08bed76b9fb78f2c7a8efa09f5c7fec3c825a631cc6a84ca4b33a6a4989217d6fb
diff --git a/dev-util/pycharm-community/pycharm-community-3.1.0.133.804.ebuild b/dev-util/pycharm-community/pycharm-community-3.1.0.133.804.ebuild
new file mode 100644
index 0000000..c2ea54f
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-3.1.0.133.804.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils versionator
+
+SLOT="$(get_major_version)"
+RDEPEND=">=virtual/jdk-1.6"
+
+PN1=${PN%-*}
+PN2=${PN#*-}
+PNS=${PN1:0:1}${PN2:0:1}
+
+MY_PV="$(get_version_component_range 4-5)"
+MY_PRE="$(get_version_component_range 6-6)"
+MY_PRE=${MY_PRE/pre/}
+
+RESTRICT="strip mirror"
+QA_TEXTRELS="opt/${P}/bin/libbreakgen.so"
+
+DESCRIPTION="PyCharm is an intelligent Python IDE"
+HOMEPAGE="http://jetbrains.com/idea/"
+
+if [ -z $MY_PRE ]; then
+ VER=($(get_all_version_components))
+ if [[ "${VER[4]}" == "0" ]]; then
+ if [[ "${VER[2]}" == "0" ]]; then
+ SRC_URI="http://download.jetbrains.com/python/${PN}-$(get_version_component_range 1-1).tar.gz"
+ else
+ SRC_URI="http://download.jetbrains.com/python/${PN}-$(get_version_component_range 1-2).tar.gz"
+ fi
+ else
+ SRC_URI="http://download.jetbrains.com/python/${PN}-$(get_version_component_range 1-3).tar.gz"
+ fi
+else
+ SRC_URI="http://download.jetbrains.com/python/${PN}-${MY_PV}.tar.gz"
+fi
+
+LICENSE="PyCharm"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)"
+
+#src_prepare() {
+# epatch ${FILESDIR}/idea-${SLOT}.sh.patch || die
+#}
+
+src_install() {
+ local dir="/opt/${P}"
+ local exe="${PN}-${SLOT}"
+ #newconfd "${FILESDIR}/config-${SLOT}" idea-${SLOT}
+ # config files
+ insinto "/etc/idea"
+# mv bin/idea.properties bin/idea-${SLOT}.properties
+# doins bin/idea-${SLOT}.properties
+# rm bin/idea-${SLOT}.properties
+# case $ARCH in
+# amd64|ppc64)
+# cat bin/idea64.vmoptions > bin/idea.vmoptions
+# rm bin/idea64.vmoptions
+# ;;
+# esac
+# mv bin/idea.vmoptions bin/idea-${SLOT}.vmoptions
+# doins bin/idea-${SLOT}.vmoptions
+# rm bin/idea-${SLOT}.vmoptions
+# ln -s /etc/idea/idea-${SLOT}.properties bin/idea.properties
+ # idea itself
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}/bin/${PN1}.sh"
+ fperms 755 "${dir}/bin/fsnotifier"
+ fperms 755 "${dir}/bin/fsnotifier64"
+ newicon "bin/${PN1}.png" "${exe}.png"
+ make_wrapper "${exe}" "/opt/${P}/bin/${PN1}.sh"
+ make_desktop_entry ${exe} "PyCharm ${PV}" "${exe}" "Development;IDE"
+ # Protect idea conf on upgrade
+ #env_file="${T}/25idea-${SLOT}"
+ #echo "CONFIG_PROTECT=\"\${CONFIG_PROTECT} /etc/idea/conf\"" > "${env_file}" || die
+ #doenvd "${env_file}"
+}