summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Haegler <simon.haegler@mistafunk.ch>2011-11-27 19:33:29 +0100
committerSimon Haegler <simon.haegler@mistafunk.ch>2011-11-27 19:33:29 +0100
commit306c17e14aaf2c2a8a2d8de04961df164a220054 (patch)
treedeab88848385957b10f6b5133846bdb29815fe22 /sci-libs/levmar/levmar-2.5-r1.ebuild
parenttest (diff)
parentuse flag fixes & manifest updates (diff)
downloadmistafunk-306c17e14aaf2c2a8a2d8de04961df164a220054.tar.gz
mistafunk-306c17e14aaf2c2a8a2d8de04961df164a220054.tar.bz2
mistafunk-306c17e14aaf2c2a8a2d8de04961df164a220054.zip
Merge branch 'master' of /home/shaegler/dev/gentoo/mistafunk-gentoo-overlay
Diffstat (limited to 'sci-libs/levmar/levmar-2.5-r1.ebuild')
-rw-r--r--sci-libs/levmar/levmar-2.5-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/levmar/levmar-2.5-r1.ebuild b/sci-libs/levmar/levmar-2.5-r1.ebuild
new file mode 100644
index 0000000..58f0a3d
--- /dev/null
+++ b/sci-libs/levmar/levmar-2.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+DESCRIPTION="Levenberg-Marquardt nonlinear least squares algorithms ANSI C implementation"
+HOMEPAGE="http://www.ics.forth.gr/~lourakis/levmar/"
+SRC_URI="http://www.ics.forth.gr/~lourakis/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/f2c-20060507
+ >=virtual/blas-1.0
+ >=virtual/lapack-3.1"
+RDEPEND="${DEPEND}"
+
+MIN_CMAKE="dev-util/cmake-1.4"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-f2c_main.patch "${FILESDIR}"/${PV}-cmake.patch
+}
+
+src_compile() {
+ if has_version ">=${MIN_CMAKE}"
+ then
+ cmake . || die "cmake failed"
+ fi
+ emake || die "make failed"
+}
+
+src_install() {
+ local my_include_dir=/usr/include/${PN}
+ insinto ${my_include_dir}
+ doins *.h
+
+ dolib liblevmar.a
+}