aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Klich <michal@michalklich.com>2015-06-14 17:48:53 +0100
committerMichael Klich <michal@michalklich.com>2015-06-14 17:48:53 +0100
commit31352e481656d70581b21810d3bb9422a538dfa9 (patch)
treeb5ef5d0e0d506c630f229e0ed36c7a6eee87f4ef
parentCleanup ebuild (diff)
downloadmklich-31352e481656d70581b21810d3bb9422a538dfa9.tar.gz
mklich-31352e481656d70581b21810d3bb9422a538dfa9.tar.bz2
mklich-31352e481656d70581b21810d3bb9422a538dfa9.zip
Trim down ebuild
-rw-r--r--dev-python/bumpversion/Manifest2
-rw-r--r--dev-python/bumpversion/bumpversion-0.5.3.ebuild15
2 files changed, 6 insertions, 11 deletions
diff --git a/dev-python/bumpversion/Manifest b/dev-python/bumpversion/Manifest
index cfe0f74..196031f 100644
--- a/dev-python/bumpversion/Manifest
+++ b/dev-python/bumpversion/Manifest
@@ -1,2 +1,2 @@
DIST bumpversion-0.5.3.tar.gz 16596 SHA256 6744c873dd7aafc24453d8b6a1a0d6d109faf63cd0cd19cb78fd46e74932c77e SHA512 2dc507be98838e4a389502cbdae08d23bad465b171923e15c40ae16da2cc9529c71dfc40213c47d23da363257b363fd5786a5661a4a6d6b568b5f8b2cf8af959 WHIRLPOOL acf125d91110edf8f02554ee9a4d30a5dfe235ffa51b8f86bc9c6298d45629d8ce56df48ef5a214351a834973dd9fe5a3eee0d1d23a99ab1ed53158da7aaa595
-EBUILD bumpversion-0.5.3.ebuild 967 SHA256 ad0120e9a513a33b557adc4a51b61b80587c67746111c450e37438ed0608baf1 SHA512 fb45a799a8ecb862a559e583830bec793232fb202866c7473e94e00e7842073d292c1cae9c0118d08082bedb43f51646f3ae3211204ed601d3549d6a27bcdaf6 WHIRLPOOL 9cf6de7bc9e938863984a7e6e7e16e1f9039e8428c856aacb9d6af7ca1f7d22ed0931e4fbbe498a1eec6462c11a6ebcf86cc90d43a32160792cfc3c0df7520fd
+EBUILD bumpversion-0.5.3.ebuild 700 SHA256 8de8a09f2adf679d9fddf18497fc51ce1309e87b3fab873e4bca58b4725e7c50 SHA512 773dca1c1c1ba8d0bd5a056277d84e0d8e301a5a34c9b98265eadaf04575d1117103143f2961277a68f1f629e9391d811b96a63da2971cff848a4bcfe738afc2 WHIRLPOOL a2a5d1d84e393f73a808e5e10add9dc5c745776168101b296ada884a46cfb2c5eae6b5c1be96d5bde777f789b6640c1c203996e98b8845f16258fba78a9f21bf
diff --git a/dev-python/bumpversion/bumpversion-0.5.3.ebuild b/dev-python/bumpversion/bumpversion-0.5.3.ebuild
index 992f69a..5c6204a 100644
--- a/dev-python/bumpversion/bumpversion-0.5.3.ebuild
+++ b/dev-python/bumpversion/bumpversion-0.5.3.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="5"
-
+EAPI=5
PYTHON_COMPAT=( python2_7 python3_{2,3,4} pypy )
inherit distutils-r1
@@ -13,12 +12,12 @@ HOMEPAGE="http://pypi.python.org/pypi/bumpversion https://github.com/peritus/bum
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="test"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
@@ -29,8 +28,4 @@ DOCS=( README.rst )
python_test() {
py.test || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-}
+} \ No newline at end of file