aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Klich <michal@michalklich.com>2015-08-09 18:41:14 +0100
committerMichael Klich <michal@michalklich.com>2015-08-09 18:41:14 +0100
commitbb7ddfc0576b4634d874273249d9bac06920c0a5 (patch)
tree4d6724c8b4cdb36b594c1c3be332f5e933c851d9 /dev-python
parentRename ebuild (diff)
downloadmklich-bb7ddfc0576b4634d874273249d9bac06920c0a5.tar.gz
mklich-bb7ddfc0576b4634d874273249d9bac06920c0a5.tar.bz2
mklich-bb7ddfc0576b4634d874273249d9bac06920c0a5.zip
Remove unfinished ebuilds
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cookiecutter/Manifest2
-rw-r--r--dev-python/cookiecutter/cookiecutter-1.0.0.ebuild47
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/cookiecutter/Manifest b/dev-python/cookiecutter/Manifest
deleted file mode 100644
index 9517886..0000000
--- a/dev-python/cookiecutter/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST cookiecutter-1.0.0.tar.gz 114813 SHA256 0217730c32b640a53eff16d268a8359f9171e15018d8c1d52a98c1da0b2b68d8 SHA512 be36d89d85761d11f64fb670c0542eb40b7cc6b0feda6453656bf9bfd8f16d332fea779c3d477a0e5422532698be29bc5e8facd2c328cc0a425e2b6e7d95e593 WHIRLPOOL 85cdd448c0325ce2f7adfb474beec0d11852d315e617760902231611bf13fb6e4f92082af5f9725b87d9cf543b5d3bdc05d71dc0435037200ffe2c28b2f9ac77
-EBUILD cookiecutter-1.0.0.ebuild 1357 SHA256 88cebf3e537827e840b423cb30d3f856e50b9b9540d88d01df8171663917caf7 SHA512 daf8f3fd457b414122eb281f4268bf06e678cdadeedd8a5bdca8111394ec2dc179b1664ab461ff128cc9d8708f5823ee4240e820b6d8eb6ced623f13830fa0fc WHIRLPOOL 06207d76df70d667bc6ef17aacdde77c69e1bd0a7773a3812b34da6091099f9427a8ab454904478cec9288b9f4f3e450497f3b0f8ee37b744589d620fa4e888d
diff --git a/dev-python/cookiecutter/cookiecutter-1.0.0.ebuild b/dev-python/cookiecutter/cookiecutter-1.0.0.ebuild
deleted file mode 100644
index 6e4e6db..0000000
--- a/dev-python/cookiecutter/cookiecutter-1.0.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A command-line utility that creates projects from cookiecutters (project templates)"
-HOMEPAGE="http://pypi.python.org/pypi/cookiecutter https://github.com/audreyr/cookiecutter"
-SRC_URI="https://github.com/audreyr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE="doc test"
-
-# TODO: dependencies must have versions
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.7
- >=dev-python/pyyaml-3.10
- <dev-python/click-4.0
- dev-python/mock[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-
-DOCS=( docs/index.rst )
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${S}"/docs/_build/html/. )
- distutils-r1_python_install_all
-}