summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2023-10-14 18:28:22 +0200
committerMartin Väth <martin@mvath.de>2023-10-14 18:28:22 +0200
commit3b38424366f1e669bb6b6b6fb4117fa85029b6eb (patch)
tree88618ae1012ee6db99ff24404d3ea607fce83f65
parentsys-apps/less: Version bump (diff)
downloadmv-3b38424366f1e669bb6b6b6fb4117fa85029b6eb.tar.gz
mv-3b38424366f1e669bb6b6b6fb4117fa85029b6eb.tar.bz2
mv-3b38424366f1e669bb6b6b6fb4117fa85029b6eb.zip
gui-wm/wayfire, gui-libs/wf-config, gui-apps/wf-shell: Version bump
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--gui-apps/wf-shell/Manifest1
-rw-r--r--gui-apps/wf-shell/metadata.xml14
-rw-r--r--gui-apps/wf-shell/wf-shell-0.8.0.ebuild47
-rw-r--r--gui-libs/wf-config/Manifest1
-rw-r--r--gui-libs/wf-config/metadata.xml14
-rw-r--r--gui-libs/wf-config/wf-config-0.8.0.ebuild43
-rw-r--r--gui-wm/wayfire/Manifest2
-rw-r--r--gui-wm/wayfire/wayfire-0.8.0.ebuild (renamed from gui-wm/wayfire/wayfire-0.7.5.ebuild)12
-rw-r--r--metadata/pkg_desc_index4
9 files changed, 133 insertions, 5 deletions
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
new file mode 100644
index 00000000..8a146481
--- /dev/null
+++ b/gui-apps/wf-shell/Manifest
@@ -0,0 +1 @@
+DIST wf-shell-0.8.0.tar.xz 9100508 BLAKE2B 0867f9968fca25d183fb912e01afc55ae6c9e3a0645eb63b2622ed53bb5d6538827a8e1bb6c68be4885f0c1513e76f0fd8f580402885bfa49dcbc7a0b8b02b49 SHA512 cdaebb4aabcfcb4a4d2ef0f7845348892e5731cc44417861b958d3f067f19b6bab002845d7663ef50f57e462664ff1ca0cdab74257109211db8fa20a47ef53ae
diff --git a/gui-apps/wf-shell/metadata.xml b/gui-apps/wf-shell/metadata.xml
new file mode 100644
index 00000000..c7d4ebcb
--- /dev/null
+++ b/gui-apps/wf-shell/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ Basic desktop environment for use with wayfire
+ which showcases all its plugins and desktop
+ effects. Integrates with other wayland
+ applications to provide a full desktop environment
+ </longdescription>
+ <upstream>
+ <remote-id type="github">WayfireWM/wf-shell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/wf-shell/wf-shell-0.8.0.ebuild b/gui-apps/wf-shell/wf-shell-0.8.0.ebuild
new file mode 100644
index 00000000..f2dfac91
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.8.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+RESTRICT="mirror"
+
+inherit meson
+
+DESCRIPTION="Compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm64 x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pulseaudio"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0=[wayland]
+ dev-libs/libdbusmenu[gtk3]
+ dev-libs/gobject-introspection
+ gui-libs/gtk-layer-shell
+ >=gui-wm/wayfire-${PV%.*}
+ pulseaudio? ( media-libs/libpulse )
+"
+RDEPEND="${DEPEND}
+ gui-apps/wayland-logout
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ -Dwayland-logout=false
+ )
+ meson_src_configure
+}
diff --git a/gui-libs/wf-config/Manifest b/gui-libs/wf-config/Manifest
new file mode 100644
index 00000000..9dd8238b
--- /dev/null
+++ b/gui-libs/wf-config/Manifest
@@ -0,0 +1 @@
+DIST wf-config-0.8.0.tar.xz 41200 BLAKE2B d56cd04c18c2cd8c0bac86493ad662244bde0e9cce1caf81d0fff34d9f2df2470c1aa8c95fead9e91dd5793d570b01dc6ef99b1986b8658b06ef93156a1526f8 SHA512 79cca2429a39ee81f853043698c57fc08025634926773253cff73fc564dcf203335b4b861d82b60a769bbab7b07be6a7e181c9ea29ad98ce930de20f9723893f
diff --git a/gui-libs/wf-config/metadata.xml b/gui-libs/wf-config/metadata.xml
new file mode 100644
index 00000000..c4c10f04
--- /dev/null
+++ b/gui-libs/wf-config/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ Library for creating and parsing the configuration
+ file for the WayfireWM while also allowing you to
+ make changes in the configuration and reload them on
+ the fly.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">WayfireWM/wf-config</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-libs/wf-config/wf-config-0.8.0.ebuild b/gui-libs/wf-config/wf-config-0.8.0.ebuild
new file mode 100644
index 00000000..68fb9c11
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-0.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+RESTRICT="mirror"
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm64 ~riscv x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ media-libs/glm
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+ test? ( dev-cpp/doctest )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test tests)
+ )
+
+ meson_src_configure
+}
diff --git a/gui-wm/wayfire/Manifest b/gui-wm/wayfire/Manifest
index 1901df5c..42f69912 100644
--- a/gui-wm/wayfire/Manifest
+++ b/gui-wm/wayfire/Manifest
@@ -1 +1 @@
-DIST wayfire-0.7.5.tar.xz 781952 BLAKE2B 10f4927d793ad2f8047ab5608db72bb5988fbb4df805dc65a87b011453729109ca0b3a92cf89e867266fae52268e1e2ac452bbd6efcc81e8f1a0c0640008adc1 SHA512 fce6d4c81fa3675df1e656f8bf504f7fc9d1b7104687bcc6d669950582f46bd0ad084c6a487434077df029438243cd91cf6ec60dc7d584b40bfd7a4c8d069f53
+DIST wayfire-0.8.0.tar.xz 828576 BLAKE2B 4d80a0d43061a4564d45f7c077fd97737b426c4036c12f004815dbad120f51b38b2fac9a010e2df27a6a96205cd0dcceb81864bdccbd6e337d81f6c37926e019 SHA512 fab55f6112c462312edf43d41b29f476d493449eca8f0c5cfee8f3aae73dcb98be46c589fc23d10d961f738bdf6d1fe78286b4c96e1d4444fdc8b1b898d998a9
diff --git a/gui-wm/wayfire/wayfire-0.7.5.ebuild b/gui-wm/wayfire/wayfire-0.8.0.ebuild
index 0a7b2d25..9c979dc4 100644
--- a/gui-wm/wayfire/wayfire-0.7.5.ebuild
+++ b/gui-wm/wayfire/wayfire-0.8.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
RESTRICT="mirror"
inherit meson toolchain-funcs
@@ -22,6 +22,7 @@ SLOT="0"
IUSE="debug +gles +system-wfconfig +system-wlroots X"
DEPEND="
+ dev-cpp/nlohmann_json
dev-libs/libinput:=
dev-libs/wayland
gui-libs/gtk-layer-shell
@@ -42,8 +43,7 @@ DEPEND="
x11-libs/libxcb
)
system-wfconfig? (
- >=gui-libs/wf-config-0.7.1
- <gui-libs/wf-config-0.8.0
+ >=gui-libs/wf-config-${PV}
)
!system-wfconfig? ( !gui-libs/wf-config )
system-wlroots? (
@@ -67,6 +67,11 @@ src_configure() {
"${FILESDIR}"/wayfire-session > "${T}"/wayfire-session || die
sed -e "s:@EPREFIX@:${EPREFIX}:" \
"${FILESDIR}"/wayfire-session.desktop > "${T}"/wayfire-session.desktop || die
+ sed -i -e 's/git\.found[(][)]/false/' "${S}/meson.build"
+ local i
+ for i in grid wm-actions scale single_plugins; do
+ sed -i -e 's:, json::' "${S}/plugins/${i}/meson.build"
+ done
local emesonargs=(
$(meson_feature system-wfconfig use_system_wfconfig)
$(meson_feature system-wlroots use_system_wlroots)
@@ -74,6 +79,7 @@ src_configure() {
$(meson_use gles enable_gles32)
$(usex debug --buildtype=debug "")
$(usex debug -Db_sanitize=address,undefined "")
+ -Ddebug_ipc=false
)
# Clang will fail to link without this
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 0e6fd379..acf09de2 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -75,7 +75,9 @@ games-engines/freesci 0.6.4-r2: Sierra script interpreter for your old Sierra ad
games-rpg/aklabeth 1.0-r1: A remake of Richard C. Garriott's Ultima prequel
games-rpg/dsa-stats 1.1: calculate stat probabalities for the role playing game DSA - Das schwarze Auge
games-rpg/m5figur-mv 4.2.2: LaTeX2e character sheet layout for the Midgard Role Playing Game (Edition M5)
-gui-wm/wayfire 0.7.5: compiz like 3D wayland compositor
+gui-apps/wf-shell 0.8.0: Compiz like 3D wayland compositor
+gui-libs/wf-config 0.8.0: library for managing wayfire configuration files
+gui-wm/wayfire 0.8.0: compiz like 3D wayland compositor
media-gfx/ipe 7.2.26: Drawing editor for creating figures in PDF or PS formats
media-gfx/libspiro 20200505-r1: A spline computation library
media-gfx/pqiv 2.11: powerful GTK based command-line image viewer with a minimal UI