summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNico Suhl <nico@overninethousand.de>2016-01-05 20:32:14 +0100
committerNico Suhl <nico@overninethousand.de>2016-01-05 20:32:14 +0100
commit287e7538c6201e10aefa5c30ae77f7a5dd083874 (patch)
tree529ca402a64c1f575e91492ac405df144fe1abd6
parentadd dev-python/colour (diff)
downloadnico-287e7538c6201e10aefa5c30ae77f7a5dd083874.tar.gz
nico-287e7538c6201e10aefa5c30ae77f7a5dd083874.tar.bz2
nico-287e7538c6201e10aefa5c30ae77f7a5dd083874.zip
add dev-python/pywapi
-rw-r--r--dev-python/pywapi/Manifest3
-rw-r--r--dev-python/pywapi/metadata.xml9
-rw-r--r--dev-python/pywapi/pywapi-0.3.8.ebuild26
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pywapi/Manifest b/dev-python/pywapi/Manifest
new file mode 100644
index 0000000..734522b
--- /dev/null
+++ b/dev-python/pywapi/Manifest
@@ -0,0 +1,3 @@
+DIST pywapi-0.3.8.tar.gz 25166 SHA256 3167e9864a6924870cb674743dc35352379d8af772280dfe2b35a00e940a4588 SHA512 c966dd73c34d695a3b63238b53781ed52a510d83bcf9495f4871e6d0016aaf0c9bb0761a5d5ab9ddbdd4b58eb758d14fbe4f4fd674e235ec2135fb3fc9d6874b WHIRLPOOL 520c126868764a7203b0fcedf4108fd2ddf7171d8506f81c176c96790d9110db93a4d231eefb57a0d50c54db0a8ba70b8698575e806c35b8b56acd81167c1aea
+EBUILD pywapi-0.3.8.ebuild 580 SHA256 94ddc231153fa11e6a88d380727127b258a098ec5154c7da373c6d8d193e3fee SHA512 d81b38fca348459fcde71df9408ff2005c1b17c53ffa9269508bec3f536487694717d1f41c69aec6c24844d3702112c96addbc66e146b8450a95100146a906bb WHIRLPOOL 5ed74cc6bfc395dd758cb5e991c3e02269ae0cfb3a32a4b3a3e488737d5b1a5a4bcd85261eee08210bcd0eacf1af76ef71e66a847f4cb9e1596a21f136efcebd
+MISC metadata.xml 399 SHA256 321479d44cea5eb4246d4684c7dd319dfb9b8a48070006425c95b443631859f5 SHA512 145c1e07f31f0f56ffdd4325c908bcc3d579c9bdad4af5730ebed50e59b1b81213a6fc358133c532a0692de0e5b0243f894ec604a1eab9c6a5ca0fa0cb949205 WHIRLPOOL 554a3a036f7729699dd4fa373c88e181f714bf2c6481aa4bd0083eb0777611251ce9209c9e6bde7d87b098468821308276c3ccac8534df464ae6ee19845c68e9
diff --git a/dev-python/pywapi/metadata.xml b/dev-python/pywapi/metadata.xml
new file mode 100644
index 0000000..fb0f296
--- /dev/null
+++ b/dev-python/pywapi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ A Python wrapper around the Yahoo! Weather, Weather.com, and National
+ Oceanic and Atmospheric Administration (NOAA) APIs. Fetch weather reports
+ using zip code, location id, city name, state, country, etc.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pywapi/pywapi-0.3.8.ebuild b/dev-python/pywapi/pywapi-0.3.8.ebuild
new file mode 100644
index 0000000..430cbd6
--- /dev/null
+++ b/dev-python/pywapi/pywapi-0.3.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around multiple weather APIs"
+HOMEPAGE="https://launchpad.net/python-weather-api"
+SRC_URI="https://launchpad.net/python-weather-api/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}