summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNico Suhl <nico@overninethousand.de>2017-08-09 17:04:16 +0200
committerNico Suhl <nico@overninethousand.de>2017-08-09 17:04:16 +0200
commit877ce40a1839995478765f47b51c3ae60962b7ac (patch)
treecf4b1e023f306e76cf653877d44868269463ea49
parentupdate telegraf to version 1.3.1 (diff)
downloadnico-877ce40a1839995478765f47b51c3ae60962b7ac.tar.gz
nico-877ce40a1839995478765f47b51c3ae60962b7ac.tar.bz2
nico-877ce40a1839995478765f47b51c3ae60962b7ac.zip
bump atom to version 1.19.0
-rw-r--r--app-editors/atom-bin/atom-bin-1.19.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-editors/atom-bin/atom-bin-1.19.0.ebuild b/app-editors/atom-bin/atom-bin-1.19.0.ebuild
new file mode 100644
index 0000000..5d7d17b
--- /dev/null
+++ b/app-editors/atom-bin/atom-bin-1.19.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit unpacker
+
+MY_PN="atom"
+DESCRIPTION="A hackable text editor for the 21st Century"
+HOMEPAGE="https://atom.io"
+SRC_URI="https://github.com/atom/atom/releases/download/v${PV}/${MY_PN}-amd64.deb"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ mkdir -p ${WORKDIR}/${P}
+ cd ${WORKDIR}/${P}
+ unpack_deb ${A}
+}
+
+src_install() {
+ cp -Rp * "${D}"
+}