summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalmer Dabbelt <palmer@dabbelt.com>2019-07-17 09:47:22 -0700
committerPalmer Dabbelt <palmer@dabbelt.com>2019-07-17 09:47:22 -0700
commit9e2237f9286dff98cf9b4b30a9054f186445ae61 (patch)
tree1103c0bc486d39411383f87923686b326e10c848
parentAdd clay dependencies (diff)
downloadpalmer-9e2237f9286dff98cf9b4b30a9054f186445ae61.tar.gz
palmer-9e2237f9286dff98cf9b4b30a9054f186445ae61.tar.bz2
palmer-9e2237f9286dff98cf9b4b30a9054f186445ae61.zip
dev-python/pycroptodomex: New ebuild
Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
-rw-r--r--dev-python/pycryptodomex/Manifest1
-rw-r--r--dev-python/pycryptodomex/pycryptodomex-3.7.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pycryptodomex/Manifest b/dev-python/pycryptodomex/Manifest
new file mode 100644
index 0000000..9409dda
--- /dev/null
+++ b/dev-python/pycryptodomex/Manifest
@@ -0,0 +1 @@
+DIST pycryptodomex-3.7.3.tar.gz 9289461 BLAKE2B 6a310e38edacb41b4b87d6a3cfbbabc2c429d4433ace7082021d47c01051ec48688eba4705ad0acf48fd85282fd5e3018fcff4ca6a01b9ce4f98e64c98a75824 SHA512 154e8a0905f3b89959f0a3d62312da8a9ef8ece6e77efc285ac80aa41ef7f5687690b7a715bc56fca9fd57f30c93f47c9717912da353ea1a1d0fd95803485623
diff --git a/dev-python/pycryptodomex/pycryptodomex-3.7.3.ebuild b/dev-python/pycryptodomex/pycryptodomex-3.7.3.ebuild
new file mode 100644
index 0000000..c13bda3
--- /dev/null
+++ b/dev-python/pycryptodomex/pycryptodomex-3.7.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://www.pycryptodome.org https://github.com/Legrandin/pycryptodome https://pypi.org/project/pycryptodome/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/gmp:0
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ !dev-python/pycrypto"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}