summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/pconfigure/pconfigure-0.11.1.ebuild')
-rw-r--r--sys-devel/pconfigure/pconfigure-0.11.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-devel/pconfigure/pconfigure-0.11.1.ebuild b/sys-devel/pconfigure/pconfigure-0.11.1.ebuild
new file mode 100644
index 0000000..3d08aeb
--- /dev/null
+++ b/sys-devel/pconfigure/pconfigure-0.11.1.ebuild
@@ -0,0 +1,37 @@
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="Palmer Dabbelt's Configure Replacement"
+HOMEPAGE="http://www.dabbelt.com/~palmer/software/pconfigure/"
+SRC_URI="https://github.com/palmer-dabbelt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 amd64-linux arm"
+IUSE="scala"
+
+RDEPEND="dev-util/pkgconfig
+ dev-util/strace
+ sys-devel/make
+ sys-devel/gcc
+ sys-libs/talloc
+ scala? ( dev-lang/scala )
+ "
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ echo "LANGUAGES += c" >> Configfile.local
+ for i in $(echo ${CFLAGS}); do
+ echo "COMPILEOPTS += ${i}" >> Configfile.local
+ done
+ echo "LANGUAGES += c++" >> Configfile.local
+ for i in $(echo ${CXXFLAGS}); do
+ echo "COMPILEOPTS += ${i}" >> Configfile.local
+ done
+ echo "COMPILEOPTS += -DPBASHC_SHEBANG=\\\"\#\!${EPREFIX}/bin/bash\\\""\
+ >> Configfile.local
+
+ sh bootstrap.sh --prefix ${EPREFIX}/usr \
+ || die "Failed to bootstap pconfigure"
+}