summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2023-10-19 14:12:59 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2023-10-19 14:12:59 +0800
commit12ead363e9fe75b806132d7ac556e0998f6ae00f (patch)
treea63b3b837c88299101d06fe605cf4855aa4c82d4
parent[net-misc/xh] new ebuild (diff)
downloadpigfoot-12ead363e9fe75b806132d7ac556e0998f6ae00f.tar.gz
pigfoot-12ead363e9fe75b806132d7ac556e0998f6ae00f.tar.bz2
pigfoot-12ead363e9fe75b806132d7ac556e0998f6ae00f.zip
[net-misc/xh] refine ebuild
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
-rw-r--r--net-misc/xh/xh-0.18.0.ebuild16
-rw-r--r--net-misc/xh/xh-0.19.1_pre20231009.ebuild16
-rw-r--r--net-misc/xh/xh-9999.ebuild16
3 files changed, 45 insertions, 3 deletions
diff --git a/net-misc/xh/xh-0.18.0.ebuild b/net-misc/xh/xh-0.18.0.ebuild
index 93653d2..acb99e9 100644
--- a/net-misc/xh/xh-0.18.0.ebuild
+++ b/net-misc/xh/xh-0.18.0.ebuild
@@ -257,15 +257,29 @@ LICENSE="MIT"
LICENSE+=" Apache-2.0 BSD ISC MIT MPL-2.0 Unicode-DFS-2016"
SLOT="0"
RESTRICT="mirror"
+IUSE="+rustls"
QA_FLAGS_IGNORED="usr/bin/${PN}"
src_unpack() {
if [[ ${PV} == *9999* ]]; then
git-r3_src_unpack
- rm -f "${S}"/Cargo.lock
cargo_live_src_unpack
else
cargo_src_unpack
fi
}
+
+src_configure() {
+ myfeatures=(
+ $(usex rustls rustls native-tls)
+ )
+
+ cargo_src_configure --no-default-features
+}
+
+src_install() {
+ cargo_src_install
+
+ dosym /usr/bin/"${PN}" /usr/bin/"s${PN}"
+}
diff --git a/net-misc/xh/xh-0.19.1_pre20231009.ebuild b/net-misc/xh/xh-0.19.1_pre20231009.ebuild
index a908501..02f03ce 100644
--- a/net-misc/xh/xh-0.19.1_pre20231009.ebuild
+++ b/net-misc/xh/xh-0.19.1_pre20231009.ebuild
@@ -279,15 +279,29 @@ LICENSE="MIT"
LICENSE+=" Apache-2.0 BSD ISC MIT MPL-2.0 Unicode-DFS-2016"
SLOT="0"
RESTRICT="mirror"
+IUSE="+rustls"
QA_FLAGS_IGNORED="usr/bin/${PN}"
src_unpack() {
if [[ ${PV} == *9999* ]]; then
git-r3_src_unpack
- rm -f "${S}"/Cargo.lock
cargo_live_src_unpack
else
cargo_src_unpack
fi
}
+
+src_configure() {
+ myfeatures=(
+ $(usex rustls rustls native-tls)
+ )
+
+ cargo_src_configure --no-default-features
+}
+
+src_install() {
+ cargo_src_install
+
+ dosym /usr/bin/"${PN}" /usr/bin/"s${PN}"
+}
diff --git a/net-misc/xh/xh-9999.ebuild b/net-misc/xh/xh-9999.ebuild
index 58b71d8..44e06a8 100644
--- a/net-misc/xh/xh-9999.ebuild
+++ b/net-misc/xh/xh-9999.ebuild
@@ -29,15 +29,29 @@ LICENSE="MIT"
LICENSE+=" Apache-2.0 BSD ISC MIT MPL-2.0 Unicode-DFS-2016"
SLOT="0"
RESTRICT="mirror"
+IUSE="+rustls"
QA_FLAGS_IGNORED="usr/bin/${PN}"
src_unpack() {
if [[ ${PV} == *9999* ]]; then
git-r3_src_unpack
- rm -f "${S}"/Cargo.lock
cargo_live_src_unpack
else
cargo_src_unpack
fi
}
+
+src_configure() {
+ myfeatures=(
+ $(usex rustls rustls native-tls)
+ )
+
+ cargo_src_configure --no-default-features
+}
+
+src_install() {
+ cargo_src_install
+
+ dosym /usr/bin/"${PN}" /usr/bin/"s${PN}"
+}