summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2016-10-04 10:38:48 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2016-10-04 10:38:48 +0800
commit07eb0ea8c6f38409f1eb9516f24cddb893664b97 (patch)
tree5835e891662bdfa6f2658bcddac0277fa7a44470 /app-admin
parent[app-admin/google-compute-engine] fix dependency of boto (diff)
downloadpigfoot-07eb0ea8c6f38409f1eb9516f24cddb893664b97.tar.gz
pigfoot-07eb0ea8c6f38409f1eb9516f24cddb893664b97.tar.bz2
pigfoot-07eb0ea8c6f38409f1eb9516f24cddb893664b97.zip
[app-admin/google-compute-engine] Version bump to 2.2.4
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/google-compute-engine/Manifest1
-rw-r--r--app-admin/google-compute-engine/files/systemd/google-accounts-daemon.service-2016080312
-rw-r--r--app-admin/google-compute-engine/files/systemd/google-clock-skew-daemon.service-2016080311
-rw-r--r--app-admin/google-compute-engine/files/systemd/google-instance-setup.service-2016080313
-rw-r--r--app-admin/google-compute-engine/files/systemd/google-ip-forwarding-daemon.service-2016080311
-rw-r--r--app-admin/google-compute-engine/files/systemd/google-network-setup.service-2016080313
-rw-r--r--app-admin/google-compute-engine/files/systemd/google-shutdown-scripts.service-2016080315
-rw-r--r--app-admin/google-compute-engine/files/systemd/google-startup-scripts.service-2016080313
-rw-r--r--app-admin/google-compute-engine/files/sysvinit/google-accounts-daemon-20160803108
-rw-r--r--app-admin/google-compute-engine/files/sysvinit/google-clock-skew-daemon-20160803107
-rw-r--r--app-admin/google-compute-engine/files/sysvinit/google-instance-setup-2016080351
-rw-r--r--app-admin/google-compute-engine/files/sysvinit/google-ip-forwarding-daemon-20160803107
-rw-r--r--app-admin/google-compute-engine/files/sysvinit/google-network-setup-2016080350
-rw-r--r--app-admin/google-compute-engine/files/sysvinit/google-shutdown-scripts-2016080350
-rw-r--r--app-admin/google-compute-engine/files/sysvinit/google-startup-scripts-2016080350
-rw-r--r--app-admin/google-compute-engine/google-compute-engine-2.2.4.ebuild46
16 files changed, 658 insertions, 0 deletions
diff --git a/app-admin/google-compute-engine/Manifest b/app-admin/google-compute-engine/Manifest
index 8c212dd..c78c9fd 100644
--- a/app-admin/google-compute-engine/Manifest
+++ b/app-admin/google-compute-engine/Manifest
@@ -1 +1,2 @@
DIST google-compute-engine-2.1.2.tar.gz 24991 SHA256 c1603145086273da11319e38361f7f63b30bb183dae34960eb02579f7c360db4 SHA512 c094c28075832b2acf9160601c680c180d3cb17db5419c16616754beeea36f85fc5208aa1c783960f3e562289efaa5c5223cc1cbc3b54997cd2340b01849b048 WHIRLPOOL 5c4fb492fc79853f909bcd92d163c9e1c76ca16e4473be75136bba6e0201d7ec54ae244141e04637225c534daf4d9cce6a06f20242cfd054bf3f6be1a421aabc
+DIST google-compute-engine-2.2.4.tar.gz 27256 SHA256 a402b9e41572bcc9ca2d724d95156ca7ec544647ada027d00407804ad2b18ef6 SHA512 81da7157dd8cbb2204f938623b107fd1cf66938dc22cfe31829053706253d17a2c72e365cf4495448dea9ee1936f6853c257708146c6d1d7d58399bf19c54284 WHIRLPOOL eb50056662163fcb1445e61cfffa678251c78eb570e1c01eb93056a03da42f9ef79256d65825227c9216bf1a5c142095b70691ca45057ae714636fd89a56601c
diff --git a/app-admin/google-compute-engine/files/systemd/google-accounts-daemon.service-20160803 b/app-admin/google-compute-engine/files/systemd/google-accounts-daemon.service-20160803
new file mode 100644
index 0000000..125e776
--- /dev/null
+++ b/app-admin/google-compute-engine/files/systemd/google-accounts-daemon.service-20160803
@@ -0,0 +1,12 @@
+[Unit]
+Description=Google Compute Engine Accounts Daemon
+After=network.target google-instance-setup.service google-network-setup.service
+Before=sshd.service
+Requires=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/google_accounts_daemon
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/google-compute-engine/files/systemd/google-clock-skew-daemon.service-20160803 b/app-admin/google-compute-engine/files/systemd/google-clock-skew-daemon.service-20160803
new file mode 100644
index 0000000..476abde
--- /dev/null
+++ b/app-admin/google-compute-engine/files/systemd/google-clock-skew-daemon.service-20160803
@@ -0,0 +1,11 @@
+[Unit]
+Description=Google Compute Engine Clock Skew Daemon
+After=network.target google-instance-setup.service google-network-setup.service
+Requires=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/google_clock_skew_daemon
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/google-compute-engine/files/systemd/google-instance-setup.service-20160803 b/app-admin/google-compute-engine/files/systemd/google-instance-setup.service-20160803
new file mode 100644
index 0000000..afa639a
--- /dev/null
+++ b/app-admin/google-compute-engine/files/systemd/google-instance-setup.service-20160803
@@ -0,0 +1,13 @@
+[Unit]
+Description=Google Compute Engine Instance Setup
+After=local-fs.target network-online.target network.target rsyslog.service
+Before=sshd.service
+Wants=local-fs.target network-online.target network.target
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/google_instance_setup
+
+[Install]
+WantedBy=sshd.service
+WantedBy=multi-user.target
diff --git a/app-admin/google-compute-engine/files/systemd/google-ip-forwarding-daemon.service-20160803 b/app-admin/google-compute-engine/files/systemd/google-ip-forwarding-daemon.service-20160803
new file mode 100644
index 0000000..d3704c6
--- /dev/null
+++ b/app-admin/google-compute-engine/files/systemd/google-ip-forwarding-daemon.service-20160803
@@ -0,0 +1,11 @@
+[Unit]
+Description=Google Compute Engine IP Forwarding Daemon
+After=network.target google-instance-setup.service google-network-setup.service
+Requires=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/google_ip_forwarding_daemon
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/google-compute-engine/files/systemd/google-network-setup.service-20160803 b/app-admin/google-compute-engine/files/systemd/google-network-setup.service-20160803
new file mode 100644
index 0000000..4400391
--- /dev/null
+++ b/app-admin/google-compute-engine/files/systemd/google-network-setup.service-20160803
@@ -0,0 +1,13 @@
+[Unit]
+Description=Google Compute Engine Network Setup
+After=local-fs.target network-online.target network.target rsyslog.service
+After=google-instance-setup.service
+Wants=local-fs.target network-online.target network.target
+
+[Service]
+ExecStart=/usr/bin/google_network_setup
+KillMode=process
+Type=oneshot
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/google-compute-engine/files/systemd/google-shutdown-scripts.service-20160803 b/app-admin/google-compute-engine/files/systemd/google-shutdown-scripts.service-20160803
new file mode 100644
index 0000000..3561089
--- /dev/null
+++ b/app-admin/google-compute-engine/files/systemd/google-shutdown-scripts.service-20160803
@@ -0,0 +1,15 @@
+[Unit]
+Description=Google Compute Engine Shutdown Scripts
+After=local-fs.target network-online.target network.target rsyslog.service
+After=google-instance-setup.service google-network-setup.service
+Wants=local-fs.target network-online.target network.target
+
+[Service]
+ExecStart=/bin/true
+ExecStop=/usr/bin/google_metadata_script_runner --script-type shutdown
+Type=oneshot
+RemainAfterExit=true
+TimeoutStopSec=0
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/google-compute-engine/files/systemd/google-startup-scripts.service-20160803 b/app-admin/google-compute-engine/files/systemd/google-startup-scripts.service-20160803
new file mode 100644
index 0000000..9c04d79
--- /dev/null
+++ b/app-admin/google-compute-engine/files/systemd/google-startup-scripts.service-20160803
@@ -0,0 +1,13 @@
+[Unit]
+Description=Google Compute Engine Startup Scripts
+After=local-fs.target network-online.target network.target rsyslog.service
+After=google-instance-setup.service google-network-setup.service
+Wants=local-fs.target network-online.target network.target
+
+[Service]
+ExecStart=/usr/bin/google_metadata_script_runner --script-type startup
+KillMode=process
+Type=oneshot
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/google-compute-engine/files/sysvinit/google-accounts-daemon-20160803 b/app-admin/google-compute-engine/files/sysvinit/google-accounts-daemon-20160803
new file mode 100644
index 0000000..4f37c52
--- /dev/null
+++ b/app-admin/google-compute-engine/files/sysvinit/google-accounts-daemon-20160803
@@ -0,0 +1,108 @@
+#!/bin/sh
+# Copyright 2016 Google Inc. All Rights Reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+### BEGIN INIT INFO
+# Provides: google_accounts_daemon
+# X-Start-Before: ssh
+# Required-Start: $local_fs $network $named $syslog $google_instance_setup
+# $google_network_setup
+# Required-Stop:
+# Default-Start: 2 3 4 5
+# Default-Stop:
+# Short-Description: Google Compute Engine Accounts Daemon
+# Description: Manages accounts from metadata SSH keys.
+### END INIT INFO
+
+# Do NOT "set -e".
+
+NAME=google-accounts-daemon
+DAEMON=/usr/bin/google_accounts_daemon
+PIDFILE=/var/run/$NAME.pid
+SCRIPTNAME=/etc/init.d/$NAME
+
+# Exit if the package is not installed.
+[ -x "$DAEMON" ] || exit 0
+
+# Load the rcS variables.
+. /lib/init/vars.sh
+
+# Depend on lsb-base (>= 3.2-14) to ensure that this file is present
+# and status_of_proc is working.
+. /lib/lsb/init-functions
+
+#
+# Function that starts the daemon/service.
+#
+do_start()
+{
+ start-stop-daemon \
+ --background \
+ --exec $DAEMON \
+ --make-pidfile \
+ --pidfile $PIDFILE \
+ --quiet \
+ --start > /dev/null
+}
+
+#
+# Function that stops the daemon/service.
+#
+do_stop()
+{
+ start-stop-daemon \
+ --exec $DAEMON \
+ --pidfile $PIDFILE \
+ --quiet \
+ --retry=TERM/30/KILL/5 \
+ --stop > /dev/null
+
+ # Wait for children to finish too if this is a daemon that forks
+ # and if the daemon is only ever run from this initscript.
+ # If the above conditions are not satisfied then add some other code
+ # that waits for the process to drop all resources that could be
+ # needed by services started subsequently. A last resort is to
+ # sleep for some time.
+ start-stop-daemon \
+ --exec $DAEMON \
+ --oknodo \
+ --quiet \
+ --retry=0/30/KILL/5 \
+ --stop > /dev/null
+
+ # Delete the pidfile when the daemon exits.
+ rm -f $PIDFILE
+}
+
+case "$1" in
+ start)
+ do_start
+ ;;
+ stop)
+ do_stop
+ ;;
+ status)
+ status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
+ ;;
+ restart|force-reload)
+ do_stop
+ do_start
+ ;;
+ *)
+ echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+:
diff --git a/app-admin/google-compute-engine/files/sysvinit/google-clock-skew-daemon-20160803 b/app-admin/google-compute-engine/files/sysvinit/google-clock-skew-daemon-20160803
new file mode 100644
index 0000000..92e1607
--- /dev/null
+++ b/app-admin/google-compute-engine/files/sysvinit/google-clock-skew-daemon-20160803
@@ -0,0 +1,107 @@
+#!/bin/sh
+# Copyright 2016 Google Inc. All Rights Reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+### BEGIN INIT INFO
+# Provides: google_clock_skew_daemon
+# Required-Start: $network $syslog $google_instance_setup
+# $google_network_setup
+# Required-Stop: $network
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: Google Compute Engine Clock Skew Daemon
+# Description: Sync the system clock on migration.
+### END INIT INFO
+
+# Do NOT "set -e".
+
+NAME=google-clock-skew-daemon
+DAEMON=/usr/bin/google_clock_skew_daemon
+PIDFILE=/var/run/$NAME.pid
+SCRIPTNAME=/etc/init.d/$NAME
+
+# Exit if the package is not installed.
+[ -x "$DAEMON" ] || exit 0
+
+# Load the rcS variables.
+. /lib/init/vars.sh
+
+# Depend on lsb-base (>= 3.2-14) to ensure that this file is present
+# and status_of_proc is working.
+. /lib/lsb/init-functions
+
+#
+# Function that starts the daemon/service.
+#
+do_start()
+{
+ start-stop-daemon \
+ --background \
+ --exec $DAEMON \
+ --make-pidfile \
+ --pidfile $PIDFILE \
+ --quiet \
+ --start > /dev/null
+}
+
+#
+# Function that stops the daemon/service.
+#
+do_stop()
+{
+ start-stop-daemon \
+ --exec $DAEMON \
+ --pidfile $PIDFILE \
+ --quiet \
+ --retry=TERM/30/KILL/5 \
+ --stop > /dev/null
+
+ # Wait for children to finish too if this is a daemon that forks
+ # and if the daemon is only ever run from this initscript.
+ # If the above conditions are not satisfied then add some other code
+ # that waits for the process to drop all resources that could be
+ # needed by services started subsequently. A last resort is to
+ # sleep for some time.
+ start-stop-daemon \
+ --exec $DAEMON \
+ --oknodo \
+ --quiet \
+ --retry=0/30/KILL/5 \
+ --stop > /dev/null
+
+ # Delete the pidfile when the daemon exits.
+ rm -f $PIDFILE
+}
+
+case "$1" in
+ start)
+ do_start
+ ;;
+ stop)
+ do_stop
+ ;;
+ status)
+ status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
+ ;;
+ restart|force-reload)
+ do_stop
+ do_start
+ ;;
+ *)
+ echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+:
diff --git a/app-admin/google-compute-engine/files/sysvinit/google-instance-setup-20160803 b/app-admin/google-compute-engine/files/sysvinit/google-instance-setup-20160803
new file mode 100644
index 0000000..4382f25
--- /dev/null
+++ b/app-admin/google-compute-engine/files/sysvinit/google-instance-setup-20160803
@@ -0,0 +1,51 @@
+#!/bin/sh
+# Copyright 2016 Google Inc. All Rights Reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+### BEGIN INIT INFO
+# Provides: google_instance_setup
+# X-Start-Before: ssh
+# Required-Start: $local_fs $network $syslog
+# Required-Stop:
+# Default-Start: 2 3 4 5
+# Default-Stop:
+# Short-Description: Google Compute Engine Instance Setup
+# Description: Runs instance setup on boot.
+### END INIT INFO
+
+NAME=google-instance-setup
+SCRIPTNAME=/etc/init.d/$NAME
+
+# Load the rcS variables.
+. /lib/init/vars.sh
+
+#
+# Function that starts the daemon/service.
+#
+do_start()
+{
+ /usr/bin/google_instance_setup > /dev/null
+}
+
+case "$1" in
+ start)
+ do_start
+ ;;
+ *)
+ echo "Usage: $SCRIPTNAME start" >&2
+ exit 1
+ ;;
+esac
+
+:
diff --git a/app-admin/google-compute-engine/files/sysvinit/google-ip-forwarding-daemon-20160803 b/app-admin/google-compute-engine/files/sysvinit/google-ip-forwarding-daemon-20160803
new file mode 100644
index 0000000..6aefc0b
--- /dev/null
+++ b/app-admin/google-compute-engine/files/sysvinit/google-ip-forwarding-daemon-20160803
@@ -0,0 +1,107 @@
+#!/bin/sh
+# Copyright 2016 Google Inc. All Rights Reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+### BEGIN INIT INFO
+# Provides: google_ip_forwarding_daemon
+# Required-Start: $network $syslog $google_instance_setup
+# $google_network_setup
+# Required-Stop: $network
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: Google Compute Engine IP Forwarding Daemon
+# Description: Manages IP forwarding.
+### END INIT INFO
+
+# Do NOT "set -e".
+
+NAME=google-ip-forwarding-daemon
+DAEMON=/usr/bin/google_ip_forwarding_daemon
+PIDFILE=/var/run/$NAME.pid
+SCRIPTNAME=/etc/init.d/$NAME
+
+# Exit if the package is not installed.
+[ -x "$DAEMON" ] || exit 0
+
+# Load the rcS variables.
+. /lib/init/vars.sh
+
+# Depend on lsb-base (>= 3.2-14) to ensure that this file is present
+# and status_of_proc is working.
+. /lib/lsb/init-functions
+
+#
+# Function that starts the daemon/service.
+#
+do_start()
+{
+ start-stop-daemon \
+ --background \
+ --exec $DAEMON \
+ --make-pidfile \
+ --pidfile $PIDFILE \
+ --quiet \
+ --start > /dev/null
+}
+
+#
+# Function that stops the daemon/service.
+#
+do_stop()
+{
+ start-stop-daemon \
+ --exec $DAEMON \
+ --pidfile $PIDFILE \
+ --quiet \
+ --retry=TERM/30/KILL/5 \
+ --stop > /dev/null
+
+ # Wait for children to finish too if this is a daemon that forks
+ # and if the daemon is only ever run from this initscript.
+ # If the above conditions are not satisfied then add some other code
+ # that waits for the process to drop all resources that could be
+ # needed by services started subsequently. A last resort is to
+ # sleep for some time.
+ start-stop-daemon \
+ --exec $DAEMON \
+ --oknodo \
+ --quiet \
+ --retry=0/30/KILL/5 \
+ --stop > /dev/null
+
+ # Delete the pidfile when the daemon exits.
+ rm -f $PIDFILE
+}
+
+case "$1" in
+ start)
+ do_start
+ ;;
+ stop)
+ do_stop
+ ;;
+ status)
+ status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
+ ;;
+ restart|force-reload)
+ do_stop
+ do_start
+ ;;
+ *)
+ echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+:
diff --git a/app-admin/google-compute-engine/files/sysvinit/google-network-setup-20160803 b/app-admin/google-compute-engine/files/sysvinit/google-network-setup-20160803
new file mode 100644
index 0000000..41b800c
--- /dev/null
+++ b/app-admin/google-compute-engine/files/sysvinit/google-network-setup-20160803
@@ -0,0 +1,50 @@
+#!/bin/sh
+# Copyright 2016 Google Inc. All Rights Reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+### BEGIN INIT INFO
+# Provides: google_network_setup
+# Required-Start: $all $google_instance_setup
+# Required-Stop:
+# Default-Start: 2 3 4 5
+# Default-Stop:
+# Short-Description: Google Compute Engine Network Setup
+# Description: Enables network interfaces on boot.
+### END INIT INFO
+
+NAME=google-network-setup
+SCRIPTNAME=/etc/init.d/$NAME
+
+# Load the rcS variables.
+. /lib/init/vars.sh
+
+#
+# Function that starts the daemon/service.
+#
+do_start()
+{
+ /usr/bin/google_network_setup > /dev/null
+}
+
+case "$1" in
+ start)
+ do_start
+ ;;
+ *)
+ echo "Usage: $SCRIPTNAME start" >&2
+ exit 1
+ ;;
+esac
+
+:
diff --git a/app-admin/google-compute-engine/files/sysvinit/google-shutdown-scripts-20160803 b/app-admin/google-compute-engine/files/sysvinit/google-shutdown-scripts-20160803
new file mode 100644
index 0000000..3f93799
--- /dev/null
+++ b/app-admin/google-compute-engine/files/sysvinit/google-shutdown-scripts-20160803
@@ -0,0 +1,50 @@
+#!/bin/sh
+# Copyright 2016 Google Inc. All Rights Reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+### BEGIN INIT INFO
+# Provides: google_shutdown_scripts
+# Required-Start:
+# Required-Stop: $remote_fs $syslog docker kubelet
+# Default-Start:
+# Default-Stop: 0 6
+# Short-Description: Google Compute Engine Shutdown Scripts
+# Description: Runs user specified shutdown scripts from metadata.
+### END INIT INFO
+
+NAME=google-shutdown-scripts
+SCRIPTNAME=/etc/init.d/$NAME
+
+# Load the rcS variables.
+. /lib/init/vars.sh
+
+#
+# Function that stops the daemon/service.
+#
+do_stop()
+{
+ /usr/bin/google_metadata_script_runner --script-type shutdown > /dev/null
+}
+
+case "$1" in
+ stop)
+ do_stop
+ ;;
+ *)
+ echo "Usage: $SCRIPTNAME stop" >&2
+ exit 1
+ ;;
+esac
+
+:
diff --git a/app-admin/google-compute-engine/files/sysvinit/google-startup-scripts-20160803 b/app-admin/google-compute-engine/files/sysvinit/google-startup-scripts-20160803
new file mode 100644
index 0000000..c9d61d1
--- /dev/null
+++ b/app-admin/google-compute-engine/files/sysvinit/google-startup-scripts-20160803
@@ -0,0 +1,50 @@
+#!/bin/sh
+# Copyright 2016 Google Inc. All Rights Reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+### BEGIN INIT INFO
+# Provides: google_startup_scripts
+# Required-Start: $all $google_instance_setup $google_network_setup
+# Required-Stop:
+# Default-Start: 2 3 4 5
+# Default-Stop:
+# Short-Description: Google Compute Engine Startup Scripts
+# Description: Runs user specified startup scripts from metadata.
+### END INIT INFO
+
+NAME=google-startup-scripts
+SCRIPTNAME=/etc/init.d/$NAME
+
+# Load the rcS variables.
+. /lib/init/vars.sh
+
+#
+# Function that starts the daemon/service.
+#
+do_start()
+{
+ /usr/bin/google_metadata_script_runner --script-type startup > /dev/null
+}
+
+case "$1" in
+ start)
+ do_start
+ ;;
+ *)
+ echo "Usage: $SCRIPTNAME start" >&2
+ exit 1
+ ;;
+esac
+
+:
diff --git a/app-admin/google-compute-engine/google-compute-engine-2.2.4.ebuild b/app-admin/google-compute-engine/google-compute-engine-2.2.4.ebuild
new file mode 100644
index 0000000..a590b4d
--- /dev/null
+++ b/app-admin/google-compute-engine/google-compute-engine-2.2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy{,3} )
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Scripts and tools for Google Compute Engine Linux images."
+HOMEPAGE="https://github.com/GoogleCloudPlatform/compute-image-packages"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-python/boto[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+
+python_install_all() {
+ for _s in google-accounts-daemon \
+ google-clock-skew-daemon \
+ google-instance-setup \
+ google-ip-forwarding-daemon \
+ google-network-setup \
+ google-shutdown-scripts \
+ google-startup-scripts;
+ do
+ newinitd "${FILESDIR}/sysvinit/${_s}-20160803" "${_s}"
+ systemd_newunit "${FILESDIR}/systemd/${_s}.service-20160803" "${_s}.service"
+ done
+
+ # Install google-compute-engine python modules.
+ distutils-r1_python_install_all
+}