summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2019-10-21 00:40:44 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2019-10-21 00:40:44 +0800
commit98186c5a9c91dd3eb32d050816d549bf1d932219 (patch)
tree8c6ae9a7b4c9d261b9d9aafb2513dd53e7d9e1e4 /net-misc
parent[net-misc/cloudflared] refine#1 (diff)
downloadpigfoot-98186c5a9c91dd3eb32d050816d549bf1d932219.tar.gz
pigfoot-98186c5a9c91dd3eb32d050816d549bf1d932219.tar.bz2
pigfoot-98186c5a9c91dd3eb32d050816d549bf1d932219.zip
Add net-misc/BaiduPCS-Go 3.6
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.ebuild38
-rw-r--r--net-misc/BaiduPCS-Go/Manifest1
-rw-r--r--net-misc/BaiduPCS-Go/metadata.xml16
3 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.ebuild b/net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.ebuild
new file mode 100644
index 0000000..1748464
--- /dev/null
+++ b/net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/iikira/${PN}"
+EGO_VENDOR=(
+)
+
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="BaiDu PCS client, written in GoLang"
+ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_VENDOR_URI}"
+SRC_URI="${ARCHIVE_URI}"
+RESTRICT="mirror"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm"
+IUSE="+pie"
+
+src_compile() {
+ use pie && local build_pie="-buildmode=pie"
+ local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
+
+ set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ GOCACHE="${T}/go-cache" \
+ CGO_ENABLED=0 \
+ GO111MODULE=off \
+ go install -v -work -x ${build_flags} ${EGO_PN}
+ echo "$@"
+ "$@" || die
+}
+
+src_install() {
+ newbin bin/${PN} baidu-pcs
+}
diff --git a/net-misc/BaiduPCS-Go/Manifest b/net-misc/BaiduPCS-Go/Manifest
new file mode 100644
index 0000000..c8cc582
--- /dev/null
+++ b/net-misc/BaiduPCS-Go/Manifest
@@ -0,0 +1 @@
+DIST BaiduPCS-Go-3.6.tar.gz 524914 BLAKE2B 8d29542d509d75ece8756b5d909dd94ca827a74a14edca668a9223df026183a79a29c3e0fd067d5cc482c2852a26a90e77231d497b1db38c20e857db228e5864 SHA512 62082f0a1bedfb495d9b096ae06effacbf917cc721ff537522fb95b15e32300927a6cbaccd94f4c2881953af8eb69782d43ac35b195c647b3b67b7c664e3f3d0
diff --git a/net-misc/BaiduPCS-Go/metadata.xml b/net-misc/BaiduPCS-Go/metadata.xml
new file mode 100644
index 0000000..d0872d2
--- /dev/null
+++ b/net-misc/BaiduPCS-Go/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pigfoot@gmail.com</email>
+ <name>Chen, Chih-Chia</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">iikira/BaiduPCS-Go</remote-id>
+ <bugs-to>https://github.com/iikira/BaiduPCS-Go/issues</bugs-to>
+ <doc>https://github.com/iikira/BaiduPCS-Go</doc>
+ </upstream>
+ <longdescription lang="en">
+ BaiduPCS Client.
+ </longdescription>
+</pkgmetadata>