summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2016-11-01 22:04:12 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2016-11-01 22:04:12 +0800
commit92255f601140452d02ef3907f59b76c60a6d2c05 (patch)
tree3fe552f1146abba4deb4f57ff316be2f0e5d4d99 /sci-libs
parent[sci-libs/xgboost] minor fix3 (diff)
downloadpigfoot-92255f601140452d02ef3907f59b76c60a6d2c05.tar.gz
pigfoot-92255f601140452d02ef3907f59b76c60a6d2c05.tar.bz2
pigfoot-92255f601140452d02ef3907f59b76c60a6d2c05.zip
[sci-libs/xgboost] minor fix4
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/xgboost/xgboost-0.60.ebuild24
-rw-r--r--sci-libs/xgboost/xgboost-9999.ebuild24
2 files changed, 40 insertions, 8 deletions
diff --git a/sci-libs/xgboost/xgboost-0.60.ebuild b/sci-libs/xgboost/xgboost-0.60.ebuild
index cbe5710..6b21f4f 100644
--- a/sci-libs/xgboost/xgboost-0.60.ebuild
+++ b/sci-libs/xgboost/xgboost-0.60.ebuild
@@ -4,12 +4,15 @@
EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+inherit distutils-r1
+
DESCRIPTION="Scalable, Portable and Distributed Gradient Boosting."
HOMEPAGE="https://github.com/dmlc/xgboost"
if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="git://github.com/dmlc/xgboost.git"
- inherit git-r3
+ EGIT_REPO_URI="git://github.com/dmlc/xgboost.git"
+ inherit git-r3
else
EGIT_COMMIT="4a8d63b6c8711fb839c71e26c659936252df1eb5"
EGIT_REPO_URI="git://github.com/dmlc/xgboost.git"
@@ -19,10 +22,21 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="static-libs"
+IUSE="+python static-libs"
DEPEND=">=sys-devel/gcc-4.6"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+src_compile() {
+ default
+ use python && cd python-package && distutils-r1_src_compile
+}
src_install() {
insinto /usr/include
@@ -30,4 +44,6 @@ src_install() {
dolib.so lib/libxgboost.so
use static-libs && dolib.a lib/libxgboost.a
dobin xgboost
+
+ use python && cd python-package && distutils-r1_src_install
}
diff --git a/sci-libs/xgboost/xgboost-9999.ebuild b/sci-libs/xgboost/xgboost-9999.ebuild
index 7d7b325..49ea285 100644
--- a/sci-libs/xgboost/xgboost-9999.ebuild
+++ b/sci-libs/xgboost/xgboost-9999.ebuild
@@ -4,12 +4,15 @@
EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+inherit distutils-r1
+
DESCRIPTION="Scalable, Portable and Distributed Gradient Boosting."
HOMEPAGE="https://github.com/dmlc/xgboost"
if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="git://github.com/dmlc/xgboost.git"
- inherit git-r3
+ EGIT_REPO_URI="git://github.com/dmlc/xgboost.git"
+ inherit git-r3
else
EGIT_COMMIT=v${PV}
SRC_URI="https://github.com/dmlc/xgboost/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
@@ -19,10 +22,21 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="static-libs"
+IUSE="+python static-libs"
DEPEND=">=sys-devel/gcc-4.6"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+src_compile() {
+ default
+ use python && cd python-package && distutils-r1_src_compile
+}
src_install() {
insinto /usr/include
@@ -30,4 +44,6 @@ src_install() {
dolib.so lib/libxgboost.so
use static-libs && dolib.a lib/libxgboost.a
dobin xgboost
+
+ use python && cd python-package && distutils-r1_src_install
}