summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Sanda <ps@twin.jikos.cz>2017-02-22 12:35:18 -0800
committerPavel Sanda <ps@twin.jikos.cz>2017-02-22 12:35:18 -0800
commita6c86518680a17c54daee2950dee921b3fce3609 (patch)
treefb9b5058a24460e5755abb8367d9210ec8336112
parentmoving words-bin to rebutia (diff)
downloadrebutia-a6c86518680a17c54daee2950dee921b3fce3609.tar.gz
rebutia-a6c86518680a17c54daee2950dee921b3fce3609.tar.bz2
rebutia-a6c86518680a17c54daee2950dee921b3fce3609.zip
drop old, using deprecated python eclass.
-rw-r--r--app-office/lyx/lyx-2.0.9999.ebuild174
1 files changed, 0 insertions, 174 deletions
diff --git a/app-office/lyx/lyx-2.0.9999.ebuild b/app-office/lyx/lyx-2.0.9999.ebuild
deleted file mode 100644
index 9a50aba..0000000
--- a/app-office/lyx/lyx-2.0.9999.ebuild
+++ /dev/null
@@ -1,174 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=3
-
-PYTHON_DEPEND="2"
-
-inherit qt4-r2 eutils flag-o-matic font python toolchain-funcs git-2
-
-MY_P="${P/_}"
-
-EGIT_REPO_URI="git://git.lyx.org/lyx"
-EGIT_BRANCH="2.0.x"
-S="${WORKDIR}/${S}"
-FONT_S="${S}/lib/fonts"
-FONT_SUFFIX="ttf"
-DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
-HOMEPAGE="http://www.lyx.org/"
-#SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/${P}.tar.xz"
-#SRC_URI="ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.0/rc3/${MY_P}.tar.xz"
-#SRC_URI="ftp://ftp.devel.lyx.org/pub/lyx/stable/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="cups debug nls latex xetex luatex monolithic-build html rtf dot docbook dia subversion rcs svg gnumeric +hunspell aspell enchant"
-
-LANGS="ar ca cs de da el en es eu fi fr gl he hu ia id it ja nb nn pl pt ro ru sk sr sv tr uk zh_CN zh_TW"
-
-for X in ${LANGS}; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-COMMONDEPEND="dev-qt/qtgui:4
- dev-qt/qtcore:4
- dev-libs/libxml2
- media-libs/fontconfig
- media-libs/freetype
- >=dev-libs/boost-1.34
- sys-devel/gettext"
-
-RDEPEND="${COMMONDEPEND}
- || ( dev-texlive/texlive-fontsextra app-text/ptex )
- || ( media-gfx/imagemagick media-gfx/graphicsmagick )
- cups? ( net-print/cups )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/noweb
- app-text/dvipng
- dev-tex/dvipost
- dev-tex/chktex
- app-text/ps2eps
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-pictures
- dev-texlive/texlive-science
- dev-texlive/texlive-genericextra
- dev-texlive/texlive-fontsrecommended
- || (
- dev-tex/latex2html
- dev-tex/tth
- dev-tex/hevea
- dev-tex/tex4ht
- )
- )
- xetex? ( dev-texlive/texlive-xetex )
- luatex? ( >=dev-texlive/texlive-luatex-2010 )
- html? ( dev-tex/html2latex )
- rtf? (
- dev-tex/latex2rtf
- app-text/unrtf
- dev-tex/html2latex
- )
- linguas_he? ( dev-tex/culmus-latex )
- docbook? ( app-text/sgmltools-lite )
- dot? ( media-gfx/graphviz )
- dia? ( app-office/dia )
- subversion? ( dev-vcs/subversion )
- rcs? ( dev-vcs/rcs )
- svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )
- gnumeric? ( app-office/gnumeric )
- hunspell? ( app-text/hunspell )
- aspell? ( app-text/aspell )
- enchant? ( app-text/enchant )"
-
-DEPEND="${COMMONDEPEND}
- x11-proto/xproto
- dev-util/pkgconfig
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- python_set_active_version 2
- font_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/2.0.3-python.patch
- echo "#!/bin/sh" > config/py-compile
- sed "s:python -tt:$(PYTHON) -tt:g" -i lib/configure.py || die
-}
-
-src_configure() {
- tc-export CXX
- #bug 221921
- export VARTEXFONTS=${T}/fonts
- WANT_AUTOMAKE=1.13 ./autogen.sh
- econf \
- $(use_enable nls) \
- $(use_enable debug) \
- $(use_enable monolithic-build) \
- $(use_with hunspell) \
- $(use_with aspell) \
- $(use_with enchant) \
- --without-included-boost --disable-stdlib-debug
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc ANNOUNCE NEWS README RELEASE-NOTES UPGRADING "${FONT_S}"/*.txt || die
-
- if use linguas_he ; then
- echo "\bind_file cua" > "${T}"/hebrew.bind
- echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind
-
- insinto /usr/share/lyx/bind
- doins "${T}"/hebrew.bind || die
- fi
-
- newicon -s 32 "$S/development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
- make_desktop_entry ${PN} "LyX" "${PN}" "Office" "MimeType=application/x-lyx;"
-
- # fix for bug 91108
- if use latex ; then
- dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx || die
- fi
-
- # fonts needed for proper math display, see also bug #15629
- font_src_install
-
- python_convert_shebangs -r 2 "${D}"/usr/share/${PN}
-
- if use hunspell ; then
- dosym /usr/share/myspell /usr/share/lyx/dicts
- dosym /usr/share/myspell /usr/share/lyx/thes
- fi
-}
-
-pkg_postinst() {
- font_pkg_postinst
-
- # fix for bug 91108
- if use latex ; then
- texhash
- fi
-
- # instructions for RTL support. See also bug 168331.
- if use linguas_he || use linguas_ar; then
- elog
- elog "Enabling RTL support in LyX:"
- elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
- elog "You must enable RTL support in LyX. To do so start LyX and go to"
- elog "Tools->Preferences->Language settings->Language"
- elog "and make sure the \"Right-to-left language support\" is checked"
- elog
- fi
-}
-
-pkg_postrm() {
- if use latex ; then
- texhash
- fi
-}