summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Sanda <ps@twin.jikos.cz>2012-08-17 01:46:06 +0200
committerPavel Sanda <ps@twin.jikos.cz>2012-08-17 01:46:06 +0200
commit7bc0b5e689f74d6ffd5120a1ee5ee15c6af3989a (patch)
tree4f96b345f7afe4b130ee4dfd59608a321c10957b /sci-biology
parentxpdf ebuilds deps (diff)
downloadrebutia-7bc0b5e689f74d6ffd5120a1ee5ee15c6af3989a.tar.gz
rebutia-7bc0b5e689f74d6ffd5120a1ee5ee15c6af3989a.tar.bz2
rebutia-7bc0b5e689f74d6ffd5120a1ee5ee15c6af3989a.zip
Add cytoscape ebuild from bugzilla and update it for 2.8.3.
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/cytoscape/Manifest2
-rw-r--r--sci-biology/cytoscape/cytoscape-2.8.3.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/cytoscape/Manifest b/sci-biology/cytoscape/Manifest
new file mode 100644
index 0000000..e6d5a8e
--- /dev/null
+++ b/sci-biology/cytoscape/Manifest
@@ -0,0 +1,2 @@
+DIST cytoscape-2.8.3.tar.gz 89722604 SHA256 7157e50582c0ec35ec66ba5cc65a36c041123577e3f8c17c48ff6457f5a008f2 SHA512 682edc4a864026584fc0f8e040acc3f2a9a4baa2c137bb9f1eb23e653c1c92930c4bc95648506fc91b8da22048b61e969e2a053e2907a715ed8576bd17676331 WHIRLPOOL 37f4b0bff54084f294d0bed511c0c9849fca13b91c7b3e5058fda21d694aa0289a976642c8dcbc96e8b5a6ae86511219f0aaad48543a2f63ac7e9afd5df45028
+EBUILD cytoscape-2.8.3.ebuild 1438 SHA256 0b07a77c264590a838b3dcb2c939c0e9274a9698e4e17143970720cf9614a96d SHA512 17675e0bca83dd6f3c5de492bc2ceefd90dc073fbdf1739c3b10598f8479fdbc433141d6572874022fd93f575cf2eedcf5d36c3f091610c040bd0eb28029e1f7 WHIRLPOOL 664b7f28d6f6e2b45ec26b3042a1dd719d15c23476cd22c1ffd7db24b09d6364a498f125de4af72d26b8122c1ca501fb756731d958c37e6027381f4d7612ce33
diff --git a/sci-biology/cytoscape/cytoscape-2.8.3.ebuild b/sci-biology/cytoscape/cytoscape-2.8.3.ebuild
new file mode 100644
index 0000000..41d7fb9
--- /dev/null
+++ b/sci-biology/cytoscape/cytoscape-2.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+EANT_ANT_TASKS="jakarta-regexp-1.4 batik-1.7 xalan xsdlib relaxng-datatype jaxb-2"
+EANT_GENTOO_CLASSPATH="swing-layout-1,stax-ex,xmlstreambuffer,sjsxp,concurrent-util,jsr173,jsr181,jsr250,fastinfoset,junit,batik-1.7,freehep-graphicsio-svg,freehep-util,freehep-xml,freehep-export,freehep-graphicsio,freehep-graphicsio-java,freehep-swing,freehep-graphicsio-ps,freehep-io,freehep-graphics2d,freehep-misc-deps,itext,piccolo2d,tclib"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+inherit versionator java-pkg-2 java-ant-2 eutils
+
+MY_PV=$(replace_all_version_separators '_')
+
+DESCRIPTION="A visualization platform for molecular interaction networks"
+HOMEPAGE="http://www.cytoscape.org/"
+SRC_URI="http://chianti.ucsd.edu/Cyto-2_8-beta/cytoscape-2.8.3.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${PN}-2.8.3"
+
+src_install() {
+ java-pkg_dojar cytoscape.jar
+ java-pkg_jarinto /usr/share/${PN}/plugins
+ java-pkg_dojar plugins/*.jar
+
+ insinto /usr/share/${PN}
+
+ # replacement for resources/bin/cytoscape.sh
+ java-pkg_dolauncher cytoscape.sh --main cytoscape.CyMain \
+ --java_args '-Dswing.aatext=true -Dawt.useSystemAAFontSettings=lcd -Xss10M -Xmx2000M' \
+ --pkg_args '-p '/usr/share/${PN}/plugins' \"$@\"'
+
+ dodoc docs/manual.pdf
+}