summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@SCU-MED-DSK-47.datys.cu>2010-03-18 18:56:03 -0400
committerroot <root@SCU-MED-DSK-47.datys.cu>2010-03-18 18:56:03 -0400
commit1f215b8bd262f88d0a1629bc10c1acd5ec77e864 (patch)
treef2aff1a884c8d3d5f035e64fa9b3d6f058d15632 /media-video/handbrake
downloadrubenqba-1f215b8bd262f88d0a1629bc10c1acd5ec77e864.tar.gz
rubenqba-1f215b8bd262f88d0a1629bc10c1acd5ec77e864.tar.bz2
rubenqba-1f215b8bd262f88d0a1629bc10c1acd5ec77e864.zip
Initial commit
Diffstat (limited to 'media-video/handbrake')
-rw-r--r--media-video/handbrake/Manifest2
-rw-r--r--media-video/handbrake/handbrake-0.9.3.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/media-video/handbrake/Manifest b/media-video/handbrake/Manifest
new file mode 100644
index 0000000..40a3ab1
--- /dev/null
+++ b/media-video/handbrake/Manifest
@@ -0,0 +1,2 @@
+DIST HandBrake-0.9.3.tar.gz 2067663 RMD160 50085816875439ee82bc213252f683352bbdbbb0 SHA1 f52389b1226bf81ba58bca67f3a1aa468cfee624 SHA256 2a776ded48285648aedaa73dd90997a0648473a2d9932203b931e7ef54393d30
+EBUILD handbrake-0.9.3.ebuild 2169 RMD160 84c4750ebb91134362cd1e876888948f6ecdab73 SHA1 1f3e9106479efea6c9be27051e1424e2d656c8f0 SHA256 512149dfb67e1c4074dad24dbc20747c669c26fc9367454ff4bae90394e6f688
diff --git a/media-video/handbrake/handbrake-0.9.3.ebuild b/media-video/handbrake/handbrake-0.9.3.ebuild
new file mode 100644
index 0000000..9c34199
--- /dev/null
+++ b/media-video/handbrake/handbrake-0.9.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+inherit eutils
+
+DESCRIPTION="Open-source DVD to MPEG-4 converter."
+HOMEPAGE="http://handbrake.fr/"
+LICENSE="GPL-2"
+SLOT="0"
+
+#real link is http://handbrake.fr/rotation.php?file=HandBrake-0.9.3.tar.gz
+#However, wget does not treat this correctly, and neither does the unpack process.
+SRC_URI="http://handbrake.fr/HandBrake-${PV}.tar.gz"
+
+KEYWORDS="x86 amd64"
+RESTRICT="fetch"
+
+#qt4 UI is broke, may just need dependancies. This USE flag does nothing.
+#Maybe you have better luck ;
+IUSE="-gtk -qt4"
+RDEPEND="
+ gtk? ( >=x11-libs/gtk+-2.8
+ >=gnome-extra/gtkhtml-3.14
+ )"
+DEPEND="sys-libs/zlib
+ dev-util/ftjam
+ $RDEPEND"
+
+
+S="${WORKDIR}/HandBrake-${PV}"
+GTK="${S}/gtk/src"
+
+pkg_nofetch() {
+ einfo "Just download the source code from"
+ einfo "${HOMEPAGE}"
+ einfo "and save it in ${DISTDIR} "
+}
+
+src_unpack() {
+ unpack "${A}"
+}
+
+src_compile() {
+
+ cd "${S}"
+
+#for local testing purposes; to prevent redownload of contribs.
+# cp -v /tmp/handbrake/HandBrake-0.9.3/contrib/*.tar.gz ./contrib
+
+ einfo "Building HandBrakeCLI."
+ make || die "make HandBrakeCLI failed"
+
+ if use gtk ; then
+ cd ${S}/gtk
+ einfo "Building ghb."
+ ./autogen.sh || die "gtk autogen.sh failed"
+ make || die "make ghb failed"
+ fi
+
+# if use qt4 ; then
+# cd ${S}/qt4
+# einfo "Building qtHB."
+# qmake || die "qmake failed"
+# make || die "make qtHB failed"
+# fi
+}
+
+src_install() {
+ into /usr
+ dobin HandBrakeCLI
+ dodoc AUTHORS BUILD CREDITS NEWS THANKS TRANSLATIONS
+ if use gtk ; then
+ dobin ${GTK}/ghb
+
+ insinto /usr/share/applications/
+ newins ${GTK}/ghb.desktop ghb.desktop
+ for res in 64 128; do
+ insinto /usr/share/icons/hicolor/${res}x${res}/apps/
+ newins ${GTK}/hb-icon${res}.png handbrake.png
+ done
+ fi
+
+# if use qt4 ; then
+# dobin ./qt4/qtHB
+# fi
+
+}
+
+pkg_postinst() {
+ einfo "HandBrakeCLI had been installed."
+ if use gtk; then
+ einfo "So has ghb, the Handbrake GUI."
+ einfo "ghb.desktop has been installed to"
+ einfo "/usr/share/applications/"
+ fi
+}
+