summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-packagekit')
-rw-r--r--gnome-extra/gnome-packagekit/Manifest3
-rw-r--r--gnome-extra/gnome-packagekit/files/gnome-packagekit-2.27.5-nls.patch11
-rw-r--r--gnome-extra/gnome-packagekit/gnome-packagekit-2.30.1.ebuild90
3 files changed, 104 insertions, 0 deletions
diff --git a/gnome-extra/gnome-packagekit/Manifest b/gnome-extra/gnome-packagekit/Manifest
new file mode 100644
index 0000000..6f39d03
--- /dev/null
+++ b/gnome-extra/gnome-packagekit/Manifest
@@ -0,0 +1,3 @@
+AUX gnome-packagekit-2.27.5-nls.patch 1088 RMD160 06f9609e28730f4c44694973f35ee68a518e30eb SHA1 e122ffb299e29983c0afffcaca7f154bdd5ba099 SHA256 dc7f6dd458ee755d8b2a1b997c82f8ce4cbbc37659ff3bae26f3b4e9249f3210
+DIST gnome-packagekit-2.30.1.tar.gz 4684513 RMD160 718a99e938cf28de72aab7b63f622195ddc80118 SHA1 d7ea6dc2a571bcfa2ec94f5b81f2c337dc903eaf SHA256 2837c4c80594dd02023222789903641a60827479a2d6750596da6292e7461c38
+EBUILD gnome-packagekit-2.30.1.ebuild 2256 RMD160 fff0b2bb52a511058ec272822e66480c1d3fa5a4 SHA1 0e28e13dbf0fc6111ac5b9f3eee431d600cbcd3c SHA256 d85dec5e9ee6e687197c508795721044d1ef2f60199dd8b97d12990fa9e873e1
diff --git a/gnome-extra/gnome-packagekit/files/gnome-packagekit-2.27.5-nls.patch b/gnome-extra/gnome-packagekit/files/gnome-packagekit-2.27.5-nls.patch
new file mode 100644
index 0000000..da1511e
--- /dev/null
+++ b/gnome-extra/gnome-packagekit/files/gnome-packagekit-2.27.5-nls.patch
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in.old 2009-08-08 17:59:08.000000000 +0200
++++ po/Makefile.in.in 2009-04-13 22:53:15.000000000 +0200
+@@ -56,7 +56,7 @@
+
+ PO_LINGUAS=$(shell if test -r $(srcdir)/LINGUAS; then grep -v "^\#" $(srcdir)/LINGUAS; else echo "$(ALL_LINGUAS)"; fi)
+
+-USER_LINGUAS=$(shell if test -n "$(LINGUAS)"; then LLINGUAS="$(LINGUAS)"; ALINGUAS="$(ALL_LINGUAS)"; for lang in $$LLINGUAS; do if test -n "`grep '^$$lang$$' $(srcdir)/LINGUAS 2>/dev/null`" -o -n "`echo $$ALINGUAS|tr ' ' '\n'|grep '^$$lang$$'`"; then printf "$$lang "; fi; done; fi)
++USER_LINGUAS=$(shell if test -n "$(LINGUAS)"; then LLINGUAS="$(LINGUAS)"; ALINGUAS="$(ALL_LINGUAS)"; for lang in $$LLINGUAS; do if test -n "`grep ^$$lang$$ $(srcdir)/LINGUAS 2>/dev/null`" -o -n "`echo $$ALINGUAS|tr ' ' '\n'|grep ^$$lang$$`"; then printf "$$lang "; fi; done; fi)
+
+ USE_LINGUAS=$(shell if test -n "$(USER_LINGUAS)" -o -n "$(LINGUAS)"; then LLINGUAS="$(USER_LINGUAS)"; else if test -n "$(PO_LINGUAS)"; then LLINGUAS="$(PO_LINGUAS)"; else LLINGUAS="$(ALL_LINGUAS)"; fi; fi; for lang in $$LLINGUAS; do printf "$$lang "; done)
+
diff --git a/gnome-extra/gnome-packagekit/gnome-packagekit-2.30.1.ebuild b/gnome-extra/gnome-packagekit/gnome-packagekit-2.30.1.ebuild
new file mode 100644
index 0000000..e31c43b
--- /dev/null
+++ b/gnome-extra/gnome-packagekit/gnome-packagekit-2.30.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+GCONF_DEBUG="no"
+
+inherit eutils python gnome2
+
+DESCRIPTION="PackageKit client for the GNOME desktop"
+HOMEPAGE="http://www.packagekit.org/"
+SRC_URI="http://www.packagekit.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="udev nls"
+
+RDEPEND="
+ udev? ( >=sys-fs/udev-145[extras] )
+ >=app-portage/packagekit-0.5.5
+ >=dev-libs/dbus-glib-0.73
+ >=dev-libs/glib-2.18.0:2
+ >=dev-libs/libunique-1.0.0:0
+ >=gnome-base/gconf-2.22:2
+ >=gnome-base/gnome-menus-2.24.1
+ media-libs/fontconfig
+ >=media-libs/libcanberra-0.10[gtk]
+ >=sys-apps/dbus-1.1.2
+ || ( sys-power/upower >=sys-apps/devicekit-power-007 )
+ >=x11-libs/gtk+-2.19.3:2
+ >=x11-libs/libnotify-0.4.3"
+DEPEND="${RDEPEND}
+ app-text/docbook-sgml-utils
+ >=app-text/gnome-doc-utils-0.3.2
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35.0
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+RESTRICT="test" # need DISPLAY
+
+DOCS="AUTHORS MAINTAINERS NEWS README TODO"
+
+# NOTES:
+# app-text/docbook-sgml-utils required for man pages
+# app-text/gnome-doc-utils and dev-libs/libxslt required for gnome help files
+# gtk-doc is generating a useless file, don't need it
+
+# UPSTREAM:
+# misuse of CPPFLAGS/CXXFLAGS ?
+# see if tests can forget about display (use eclass for that ?)
+# intltool and gettext only with +nls
+
+pkg_setup() {
+ # localstatedir: /var for upstream /var/lib for gentoo
+ # scrollkeeper and schemas-install: managed by gnome2 eclass
+ # tests: not working (need DISPLAY)
+ # gtk-doc: not needed (builded file is useless)
+ G2CONF="
+ --localstatedir=/var
+ --enable-option-checking
+ --disable-dependency-tracking
+ --enable-libtool-lock
+ --enable-compile-warnings=yes
+ --enable-iso-c
+ --disable-scrollkeeper
+ --disable-schemas-install
+ --disable-tests
+ --disable-gtk-doc
+ --disable-strict
+ $(use_enable nls)
+ $(use_enable udev gudev)"
+}
+
+src_prepare() {
+ # fix pyc/pyo generation
+ rm py-compile || die "rm py-compile failed"
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize $(python_get_sitedir)/packagekit/
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/packagekit/
+}